Support » Plugin: WP Cloudflare Super Page Cache » Caching not working on static and dynamic pages

  • Resolved Natasha_Tracy

    (@natasha_tracy)


    When I test the cache, I get this:

    Page caching seems not working for both dynamic and static pages.

    Error on dynamic page (https://natashatracy.com): Seem that your website is not behind Cloudflare. If you have recently enabled the cache or it is your first test, wait about 30 seconds and try again because the changes take a few seconds for Cloudflare to propagate them on the web. If the error persists, request support for a detailed check.

    Error on static resource (https://natashatracy.com/wp-content/plugins/wp-cloudflare-page-cache/assets/testcache.html): Seem that your website is not behind Cloudflare. If you have recently enabled the cache or it is your first test, wait about 30 seconds and try again because the changes take a few seconds for Cloudflare to propagate them on the web. If the error persists, request support for a detailed check.

    Please check if the page caching is working by yourself by surfing the website in incognito mode ’cause sometimes Cloudflare bypass the cache for cURL requests. Reload a page two or three times. If you see the response header cf-cache-status: HIT, the page caching is working well.

    Does anyone have an idea for how to troubleshoot this? (I check it in an incognito window too and it appears to not be working that way either.)

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 22 total)
  • @natasha_tracy This error usually appears when you already have a cache plugin installed and the page cache is active. With this plugin there is no need for another cache plugin

    @natasha_tracy visiting his website he is not on the cloudflare. If you have already made a DNS change on your server, you need to wait for the DNS to propagate and you can check this site https://dnschecker.org/#NS/natashatracy.com

    Right now your website is pointing to Bluehost.

    Thread Starter Natasha_Tracy

    (@natasha_tracy)

    Hi,

    I’m sorry, I didn’t see anywhere that I had to change the DNS. Is there a document somewhere that talks about this?

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Hi @natasha_tracy,
    Looking at your website it seems the problem lies with your site is not using Cloudflare, to begin with. So, even though you are installing the plugin it cannot do anything as Cloudflare is not active in your system. Your nameserver showing is:

    
    ns1.bluehost.com
    ns2.bluehost.com
    

    And as you can see it is not pointing to cloudflare as @laserstore mentioned. If ou are enabling cloudflare from your bluehost dashboard, don’t do that. Go to cloudflare website and create an account and set up this plugin. Watch the following videos:


    Thread Starter Natasha_Tracy

    (@natasha_tracy)

    Hi,

    After some further investigation, Cloudflare says that Bluehost is a Cloudflare partner and the settings have to be managed there. And when you go there, Cloudflare is a beta feature that’s not working.

    So it looks like I’m stuck without it.

    Thank you for your help.

    Plugin Contributor Saumya Majumder

    (@isaumya)

    As I said, if you want to take advantage of Cloudflare you don’t want a Bluehost managed Cloudflare account. Create a free Cloudflare account yourself, point your nameservers to Cloudflare nameserver. Use your Cloudflare account’s API details in the plugin and you are good to go.

    Thread Starter Natasha_Tracy

    (@natasha_tracy)

    Unfortunately, the CloudFlare site itself is saying it needs to be managed by Bluehost because they are a “partner.”

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Ity’s not. Go to https://www.cloudflare.com/ Slick on Sign up and then follow the process. Check this video I shared above:

    Thread Starter Natasha_Tracy

    (@natasha_tracy)

    Hi,

    I watched the video, and I did add my site to Cloudflare, but when I click on DNS in Cloudflare, it says this:

    “Partner hosted zone
    Your DNS zone file is hosted by Bluehost, a Cloudflare partner. Manage your DNS records at their website.”

    So I don’t know where to go from there.

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Yes just ignore that and change your nameserver to the nameserver provided by Cloudflare after you added your domain in the Cloudflare account you have created and for that point manage your DNS in Cloudflare directly and not in Bluehost.

    Thread Starter Natasha_Tracy

    (@natasha_tracy)

    Hi,

    In the end, I had to remove my website from Cloudflare and then re-add it. When I did that, I was able to walk through the process outlined in the video, so thank you for that.

    WP Cloudflare Super Page Cache still says that the cache isn’t working, but I think it actually is as I’m seeing web traffic through Cloudflare.

    Thank you for all your help.

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Thank is awesome news @natasha_tracy. Maybe your nameserver change hasn’t been propagated everywhere. Remind me to check your site tomorrow again in case I forget as your nameserver change hasn’t propagated in my location yet (it generally takes 24 hours).

    Thread Starter Natasha_Tracy

    (@natasha_tracy)

    Hi,

    Just to let you know, the plugin still says the caching isn’t working, but I think it is.

    Thanks.

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Hey, sorry! No the cache is still not working. Can you share a screenshot of your Cloudflare DNS page? Just need to make sure for your main A and CNAME & A record orange could is enabled or not.

    Also send the screenshot of the page rule section in from your Cloudflare dashboard.

    Thread Starter Natasha_Tracy

    (@natasha_tracy)

    I realize this is going to make me seem like an idiot, but how do I share a screenshot? There doesn’t seem to be a way of attaching anything to the reply.

Viewing 15 replies - 1 through 15 (of 22 total)
  • You must be logged in to reply to this topic.