Support » Plugin: LiteSpeed Cache » Caching issues

  • Resolved mgsolidus

    (@mgsolidus)


    Hi,

    Report number: TLPIKAKY
    Report date: 07/26/2019 09:05:55

    For all CSS and JS files, the following headers are present:

    x-litespeed-cache: miss
    cache-control: no-store, no-cache, must-revalidate

    How can I make these and other static files cacheable?
    I’m using CloudFlare, CyberPanel and OpenLiteSpeed.

    Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi @mgsolidus, normally the static file will not cache by server, you can turn on browser cache on: LiteSpeed Cache > Settings > Advanced > Browser Cache

    Thread Starter mgsolidus

    (@mgsolidus)

    Hi,

    This setting is already on. Does OpenLiteSpeed use the .htaccess settings this plugin defines?
    I was hoping to edit the cache-control settings for static files.

    Thread Starter mgsolidus

    (@mgsolidus)

    I have another question as well.
    The only Litespeed header for static files is this one,

    x-turbo-charged-by: LiteSpeed

    does this mean it is cached or not?
    I noticed that the page itself has these headers as well,

    x-litespeed-cache
    x-litespeed-tag

    It would be nice if static files had these headers so I can easily see if they are cached.

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    For OLS, you need to follow this guide to enable browser cache.

    Yes, static files doesn’t need to use LiteSpeed Cache , that turbo-charged header is showing when you are running behind CloudFlare.

    Best regards,

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Caching issues’ is closed to new replies.