WordPress.org

Support

Support » Plugins and Hacks » Geo Mashup » [Resolved] Caching error transients

[Resolved] Caching error transients

  • Hi – I’m getting this issue all of a sudden, everything was working fine as of yesterday: WordPress transients may not be working. Try deactivating or reconfiguring caching plugins. issue 425

    I read the entire forum discussion concerning this issue and I don’t use W3 Total Caching or any other site caching plugins. How can I resolve?

    http://wordpress.org/plugins/geo-mashup/

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author Dylan Kuhn

    @cyberhobo

    Do you get any failure messages in Settings / Geo Mashup / Tests?

    Thanks for the quick reply! Everything looks clean in the tests:

    Tests completed in 7196 milliseconds.
    58 assertions of 58 passed, 0 failed.

    I just added this line to my robots.txt: Disallow: /?geo_mashup_content=render-map*

    Just checked again with a clean browser cache and the issue is still there. Thoughts?

    I just realized that if I create a new map, this generates a new map_data_key and resolves the issue. Interesting. This is probably a temporary fix, and will likely happen again, right?

    Plugin Author Dylan Kuhn

    @cyberhobo

    Probably. Something is behaving like an object cache on your site. It could be your host or another plugin. A reliable solution would require figuring that out.

    I do plan to make Geo Mashup less dependent on transients in future versions to avoid situations like this, but clearly I’m not there yet.

    OK, thanks. In the meantime, I’ll see if the robots.txt does the trick, contact my web host, and hand-replace the iframe source every few days if necessary. Again, I appreciate the quick reply and the help!

    Plugin Author Dylan Kuhn

    @cyberhobo

    The robots.txt entry just prevents search engines from getting errors, it does nothing for regular users.

    If you’re lucky this is a one-time glitch with a single transient. I’d be interested to hear anything you figure out.

    If it happens again and / or I learn anything from my web host, I’ll let you know!

    The transients issue happened again. My web host says that we do have a PHP caching extension called xcache installed. I’m running other websites on this server where speed is a must, so I can’t disable xcache for the purposes of this plugin, unfortunately. Do you have or know of a workaround for this?

    Plugin Author Dylan Kuhn

    @cyberhobo

    Depending on your hosts’ configuration you may be able to disable xcache for a single domain:

    http://www.computersolutions.cn/blog/2011/11/how-to-disable-xcache-per-domain/

    If not, you’ll have to wait for a Geo Mashup version with optional transients.

    I’ll give that a try… thanks again!

    Plugin Author Dylan Kuhn

    @cyberhobo

    I have a beta version of 1.7 I’d like your feedback on if you can try it. Download here:

    https://code.google.com/p/wordpress-geo-mashup/downloads/list

    Awesome! I made a few customizations to the plugin to fit my site (custom marker, etc) – could you tell me which file(s) changed?

    Plugin Author Dylan Kuhn

    @cyberhobo

    Hopefully you’re not modifying geo mashup files – use the companion geo-mashup-custom plugin instead:

    https://code.google.com/p/wordpress-geo-mashup/wiki/Documentation#Custom_JavaScript

    But here’s a quick list of changed files:

    .travis.yml                           |  17 ++++
     build.xml                             |   8 +-
     default-templates/full-post.php       |   2 +-
     default-templates/info-window-max.php |   2 +-
     default-templates/info-window.php     |   2 +-
     default-templates/search-form.php     |   8 +-
     geo-mashup-db.php                     | 254 ++++++++++++++++++++++++------------------------------
     geo-mashup-search.php                 |   3 -
     geo-mashup.php                        |  49 ++++++-----
     geo-query.php                         |   6 +-
     gm-int-list.php                       |  89 +++++++++++++++++++
     gm-location-query.php                 | 139 ++++++++++++++++++++++++++++++
     js/geo-mashup-google.dev.js           |   9 +-
     js/geo-mashup-markerclusterer.dev.js  |   4 +-
     js/geo-mashup-mxn.dev.js              |  36 +++++---
     js/geo-mashup.dev.js                  |   8 ++
     js/loader.dev.js                      |   2 +
     js/location-editor.dev.js             |  30 ++-----
     js/mxn/mxn.core.dev.js                |   9 +-
     js/mxn/mxn.googlev3.core.dev.js       |  51 ++++-------
     js/mxn/mxn.openlayers.core.dev.js     |   4 +-
     js/qunit-tests.dev.js                 |   4 +-
     js/taxonomy.dev.js                    |  31 ++++++-
     post-query.php                        |  38 ++++++++
     readme.txt                            |  11 +--
     release-checklist.txt                 |   5 +-
     render-map.php                        |  22 +++--
     tests/bootstrap.php                   |  11 ++-
     tests/test-geo-mashup.php             | 145 ++++++++++++++++++++-----------
     tests/test-gm-int-list.php            |  43 +++++++++
     tools/install-wp-tests.sh             |  32 +++++++
     31 files changed, 744 insertions(+), 330 deletions(-)

    OK – I’ve got the new version installed. So far so good. I’ll let you know if I encounter any other transients notifications. Thanks!

    The new version is working flawlessly so far. Thank you! Do you think it’s safe to add back xcache or any other caching script like APC?

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Resolved] Caching error transients’ is closed to new replies.
Skip to toolbar