Support » Plugin: AmazonSimpleAdmin » Caching does not seem to work

  • Resolved fjordkommission

    (@fjordkommission)


    Hi Timo,

    due to the discontinuation of the API4 and the official Amazon Associates Link Builder plugin, I am currently in the process of migrating all my links to ASA1.

    As I haven’t had any sales via PA-API5 yet, the number of requests is throttled by Amazon (10 per minute? idk).

    On my pages I have various products with several different templates, which in total exceed the limit of requests. So I thought, I would cache each product individually first, keep the cache for a number of days and have my overview page only use the cache instead of the PA-API. So I made a page with only one product in it, and replaced the ASIN after each page load. This way, all the products now are stored in the cache folder.

    However, although all ASINs are stored in the cache, I still get Error 429 for most of them. It seems that ASA1 is not fetching them from the cache but still tries to get them from the API.

    Do I miss any setting maybe?

    If you need more details (logs, screenshots, anything) please get back to me. 🙂

    Cheers,
    Sascha

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • I found the rules, if anyone is interested: https://webservices.amazon.com/paapi5/documentation/troubleshooting/api-rates.html

    PA-API5 limits the number of requests to 1 per second and to 8640 per day, unless the associate has generated a certain revenue in the last 30 days.

    To get 1 request per second more, you have to make a revenue of 4320 USD.

    For each 5 Cents of revenue you get 1 request per day on top.

    This is really harsh.

    Uh, wait… could it be that caching is disabled for logged in users?

    When I open the page in a different browser, with which I am not logged into WordPress, the products all load fine. In the page preview from the WP editor, though, I still get the errors.

    My apologies if I overlooked a hint in the documentation, if that is intended behaviour.

    EDIT: DOH! Yes, it does. There is even a checkbox in the plugin settings.

    I feel so embarrassed now. 😀

    Never mind my stupid question.

    Plugin Author Timo

    (@worschtebrot)

    Hi Sascha,

    you’re right. There is an option to disable the cache if you are logged in as admin. This is meant so that you don’t always have to empty the cache to see your changes while creating new content.

    Don’t worry about your question, there are no stupid questions. 😉
    I appreciate any feedback from the users of my plugin.

    …. edit… question answered by myself…

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Caching does not seem to work’ is closed to new replies.