Support » Plugin: W3 Total Cache » Caching disabled for home page

  • Resolved Chad Reitsma

    (@chadreitsma)


    Hey guys,

    We have a couple of client sites where caching isn’t working on the home page (both Page caching and the CDN are not active).

    If I inspect the page, no W3 comments are appended to the HTML.

    “Don’t cache front page” is Unchecked, and I have tried both logged in, and logged out (in an incognito window).

    Has anyone ever run into this before? Any help is appreciated! 🙂

    Cheers,
    C.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @chadreitsma

    Thank you for reaching out and I am happy to assist you with this.
    The W3TC HTML comment may be removed if HTML minify is enabled. Go to Performance>Minify, and under the HTML&XML section add Performance to Ignored comment stems: field.
    Save all settings and purge the cache and check if the HTML output is showing.
    Thanks!

    Thread Starter Chad Reitsma

    (@chadreitsma)

    Hi Marko,
    HTML minify is disabled.

    It seems like the whole caching system is disabled for the front page (only), if we browse to any other page I can see the CDN urls, and also W3’s comment output. I’m just not sure why it isn’t working on the front page.

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @chadreitsma

    Thank you for the infomation.
    Well, this is very strange indeed. Can you please share the URL you are experiencing the problem on and also the page on which you can see the HTML snippet.
    Thanks!

    Thread Starter Chad Reitsma

    (@chadreitsma)

    Hi Marko,
    Thanks for your reply, we got it figured out!

    One of our developers made a mistake and was echoing something out before get_header(); That was causing the page to enter Quirks mode / messing up the <!DOCTYPE>, so W3 must have ignored the page. Sorry for wasting your time here, and thank-you for trying to help!

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @chadreitsma

    Thank you for the information.
    No problem, that is what we are here for.

    We would really appreciate it if you could take a minute and post a review here. This will help us to continue offering a top-notch product to users.
    Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Caching disabled for home page’ is closed to new replies.