• Resolved justrelaxed

    (@justrelaxed)


    Hi,

    The mobile homepage version only shows up on mobile phones if I change the homepage via the mobile icon and save it. When I change the homepage desktop version via the desktop icon and save it, it also show the destop version again for mobile visitors.

    I use Litespeed caching and Cloudflare. Can I get it work steady?
    I hope you can help me out here.

    Best regards,
    Sander

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jose

    (@giuse)

    Hi @justrelaxed

    honestly, I’m not sure I have understood.

    if I change the homepage via the mobile icon

    Does it mean “when you change and save the mobile version of the homepage”?

    When I change the homepage desktop version via the desktop icon

    Does it mean “when you change and save the mobile version of the homepage”?

    In any case, inspecting elements on your homepage, it looks like Specific Content For Mobile is not running on mobile, even without page cache.

    First, try disabling Redis Object Cache to see if it’s the cause of the issue. If it’s confirmed, I will try to solve the conflict.
    If Redis Object Cache has nothing to do with the issue I will give you more suggestions.

    • This reply was modified 2 years, 1 month ago by Jose.
    Thread Starter justrelaxed

    (@justrelaxed)

    Hi Jose,

    Thank you kindly for the response.

    I deactivated your plugin because I have a high traffic website and the specific content for mobile was not working the last days as it should.

    I disabled Redis Caching now and activate your plugin again.
    When I edit the homepage via the mobile icon and save it. The mobile page is now showing up on mobile phone but also on the desktop. for desktop I just need the normal homepage.

    When I edit and save the homepage via the desktop icon and check on mobile I get the desktop version again on mobile.

    https://ibb.co/jL1rfRN

    • This reply was modified 2 years, 1 month ago by justrelaxed.
    Plugin Author Jose

    (@giuse)

    Hi @justrelaxed

    I suggest you go to LiteSpeed Cache => Cache (first tab), and activate “Cache mobile”. Read here for more details: https://docs.litespeedtech.com/lscache/lscwp/cache/#cache-mobile
    If that option is not “ON”, it will never work.

    Then delete the cache and check again.

    Let me know if it works.

    Thread Starter justrelaxed

    (@justrelaxed)

    Hi Jose,

    Thanks a lot for the reply.

    You are right, LiteSpeed ‘Cache mobile’ was disabled in the plugin. I enabled it now and delete the cache but when I check the website on my mobile I still see the desktop version.

    * after a few refreshes I do see the mobile version on mobile
    ** but the mobile version also again for desktop visitors when I check incognito

    I disabled specific content for mobile temporary else it’s a mess for desktop visitors.

    Plugin Author Jose

    (@giuse)

    Hi @justrelaxed

    you don’t have only LiteSpeed Cache, but also Cloudflare. Be sure that the cache of Cloudflare distinguishes between desktop and mobile.

    The plugin does always the same. If sometimes you see it right and sometimes not, it’s a matter of cache.

    It looks you need a business Cloudfare plan to distinguish between mobile and desktop. You can read here: https://community.cloudflare.com/t/cache-everything-breaks-mobile-site/10337/2

    Plugin Author Jose

    (@giuse)

    For other users who may read this thread, the issue was caused by Cloudflare.

    @justrelaxed

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Cachin problem?’ is closed to new replies.