Support » Plugin: ShortPixel Adaptive Images » Cached version not using Shortpixel CDN

  • Hi,

    I use WP Rocket as my caching plugin. I have set up Adaptive Images from ShortPixel and use Shortpixel CDN to serve WebP images and to all optimization.

    I also use Cloudflare which settings I inputted in ShortPixel.

    Everything works fine when I check uncached version (it is not served for users login to the site).

    Do I need to do any extra steps for it so Shortpixel works with WP Rocket?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author ShortPixel

    (@shortpixel)

    Hello @amazinghulk – thank you for using ShortPixel! 🙂

    1) Please note that you need to keep lazy loading in WP Rocket off, learn more here:
    https://shortpixel.helpscoutdocs.com/article/220-i-installed-shortpixel-adaptive-images-but-it-doesnt-seem-to-work
    2) the Cloudflare settings in ShortPixel Image Optimizer are not necessary if you use ShortPixel Adaptive Images.
    3) I’m not sure I understand what you mean by “Everything works fine when I check uncached version (it is not served for users login to the site).” – can you please explain?
    4) you may also want to check this article to make sure SPAI is working OK on your website:
    https://shortpixel.helpscoutdocs.com/article/240-is-shortpixel-adaptive-images-working-well-on-my-website

    Hi,

    Thank you for your response.

    1) Can I keep the lazy load on WP Rocket but disable on ShortPixel?

    2) I don’t use ShortPixel Image Optimizer plugin just ShortPixel Adaptive Images as that is how you recommend in your documentation.

    3) I wanted to say that I can see that ShortPixel Adaptive Images work on uncached version but when I check the cached version I don’t see nor WebP nor ShortPixel CDN in URL.

    Plugin Author ShortPixel

    (@shortpixel)

    Hello again!

    1) no, you cannot turn off lazy load in ShortPixel as it will stop working at all. But you could try to use ShortPixel Image Optimizer with WP Rocket lazy load if you wish.
    2) OK, is there something that you need assistance with then?
    3) maybe you need to flush cache first and then you’ll also see SPAI working as well?

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.