Support » Plugin: Super Page Cache for Cloudflare » Cached HTML pages showed cf-cache-status: MISS

  • Hello,

    For some reason even if I see many cashed html pages in the list, when I try to visit one link in incognito mode I can see the delay and the cf-cache-status: MISS.

    If I instantly revisit the link it opens very fast and I see cf-cache-status: HIT.
    But after a few moments the same miss again I don’t know why this is happening I use the plugin for about 3-4 months now but I never had the time to investigate deeper!

    –ENABLED SETTINGS–

    1. The plugin TEST Page caching is working properly
    2. Purge cache for related pages only – (recommended)
    3. Purge HTML pages only
    4. Cloudflare Cache-Control max-age 31536000
    5. Browser Cache-Control max-age 60
    6. Enable preloader
    7. Automatically preload the pages you have purged from Cloudflare cache
    8. Auto prefetch URLs on mouse hover

    I am using a VPS with plesk-nginx PHP-FMP
    In my cloudflare profile I can see the https://sportlive.gr/*
    Cache Level: Cache Everything

    –EXAMPLE–

    This below link for example I can see it in the caching list, but if I try to visit it its MISS again!

    https://sportlive.gr/celebrities/eleni-menegaki-pozarei-agoyroxypnimeni-choris-ichnos-makigiaz/

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Mat

    (@mateithemeisle)

    Hello @diriras ,

    Thank you for using this plugin and for reaching out!

    I have checked your website and it seems to be working fine for me, indeed it showed status as a miss for the first attempt but only got hit afterward meaning that the website was served from the nearest Cloudflare datacentre.

    Are you still encountering issues?

    Thank you and we’ll await your answer!

    Thread Starter diriras

    (@diriras)

    Hello Mat thanks for the reply,

    The trouble is that in the first hit I always have delays and misses!
    I thought that the purpose of this plugin was to cache the links permanently in cloudflare servers as I can see in the plugin settings for at least a year!

    Recommended 31536000 (1 year)

    What’s the point of caching for a few minutes and then miss and then re-caching again?
    My website is not served from Cloudflare datacenter at the first visit! But the viewer needs the first hit, he will not refresh the page to get it from cloudflare the second time it has no point!

    Plugin Contributor Saumya Majumder

    (@isaumya)

    I thought that the purpose of this plugin was to cache the links permanently in cloudflare servers as I can see in the plugin settings for at least a year!

    – Yes the plugin ask Cloudflare to cache the items for 1 year but it is up to cloudlfare for how long it want to cache it. Read this section of the article which will help you understand CF cache behaviour: https://acnam.com/untold-truths-of-cloudflare-cdn/#cloudflare-cache-creation-replication-storage

    My website is not served from Cloudflare datacenter at the first visit!

    – When a page ie being loaded for the first time, it will always be served from origin server as the origin server needs to generate the page HTML. Then it gets cached and served to subsequent requests. I will also recommend you to enable the Tired Cache inside CF Dashboard > Caching Tab. Tired cache will reduce your global cache miss greatly.

    Also do check if you have any other page rule inside CF dashboard that might be tinkering with the cache behaviour. There is supposed to be only 1 page rule that is added by this plugin i.e. the cache everything rule and beside that there is not supposed to be any other page rule that modifies the cache behaviour in any way for that site. As all caching is handled by the plugin.

    Also inside CF dashboard > caching tab check if the browser cache TTL section is set to respect existing header.

    If possible share a screenshot of both of these section from your CF dashboard.

    Thread Starter diriras

    (@diriras)

    Hello Saumya,

    Yes the page rules are set correcty in the panel: https://sportlive.gr/*
    Cache Level: Cache Everything
    Also the Browser Cache TTL is set to respect existing headers as well in the Cloudflare Panel!

    I know that the first time a webpage is supposed to load from the origin server, that is understood, and if I press refresh then I have an instant response and I can see the cf-cache-status: HIT status. This is working for a while but then, after a few minutes or new posts, I always have the same page loaded again from the origin server, I can understand this because of the delay and the miss status in the cf-cache-status:

    The cache level in the plugin panel is set to Purge cache for related pages only – (recommended) and it is working fine, when I have a new post it is getting refreshed from the plugin when I had fallback page cache disabled!

    Now the odd thing is that today after a long time I enabled fallback page cache so theoretically I have enabled disk cache. And now as I can see the cache is working and not lost after a few minutes. It keeps sending me HIT results from cf-cache-status and the page is opened instantly also after several minutes or new posts!
    The downside I noticed in the fallback page cache option is that the cached posts and Homepage are not synced exactly with the non cached version the of the website!

    I can see different version of the homepage in the https://sportlive.gr/?swcfpc=1
    and a few posts back in the cached one https://sportlive.gr from ex. incognito window.
    This means that the option Automatically purge the fallback cache when Cloudflare cache is purged is somewhat delayed or misfired with the result to not have the Homepage updated with the latest posts each time! So I performed Purge fallback cache manually to see if the homepage will get updated with negative results!

    So now I tried to Use cURL and Purge fallback cache manually also to test for an updated version of the Homepage but also with no result. The posts are not updating instant in the cached version, it just need more time for some reason…

    So my final thoughts are the below:

    When fallback cache off and Purge cache for related pages only – (recommended) on, the plugin is working like its purging ALL the cache and I can see the updated posts and homepage in the cached version but after a while or new post, it keeps requesting the pages from the origin server so the caching is not working like it should, with delays and with the cf-cache-status MISS !

    When I Enable fallback page cache option, I have all my pages cached and INSTALY loading from web browsers with the HIT from cf-cache-status BUT, I don’t have the latest updated posts and homepage version in the cached version! It looks like the plugin needs more time to cache the latest posts and I don’t know the pattern, the trick to make it cache the latest posts.

    For the reference I surely DONT use any other performance/caching plugins and I use the WordPress Newspaper Theme , the No1 top selling theme in WordPress.

    Plugin Contributor Saumya Majumder

    (@isaumya)

    If you have a high traffic website, and Tired Cache is on in CF account, you can try using your site for a few days with fallback cache deactivated and check if you see any changes. It is mostly helpful on low traffic sites.

    Thread Starter diriras

    (@diriras)

    I don’t have a high traffic website, only 2500K users per day, and tired cache does not have any different impact on the website.

    When I disable the cache purging using queue in the plugin, the issue was resolved in a way that, caching purge is working when new or update post is happening BUT the homepage still words as was coming from the origin server with delays etc..

    Also after a whole day with fallback cache activated, my WP backend was starting to LAG very much is a way that a simple post edit took almost 4-5 minutes to complete!
    When I purge the fallback cache, the backend started to work as expected once more. This tells us that ONLY fallback cache is working and its also buggy.

    So I put the following rule only to failsafe and pray to work.
    prevent the following URIs to be cached: /wp-admin*

    To sum it up back then when Cloudflare caching was working, all were fine I only had trouble to cache my mobile template so now that I cancel the mobile theme I don’t even have the default Cloudflare caching option, I only have the failsafe one and I also have some troubles with it now.

    I also have a Pre-prod website, a cloned one to Production and surely actions and tests needs to be performed from the developer of this plugin because it is far from working as expected!!

    Plugin Contributor Saumya Majumder

    (@isaumya)

    I don’t have a high traffic website, only 2500K users per day, and tired cache does not have any different impact on the website.

    – That is hard to believe. You see the way tiered cache works is that when you r content is cached in CF CDN, other CF locations mostly will not send another request to your origin and instead fetch directly from the CF internal network. You can read more about tired cache in CF blog.

    When I purge the fallback cache, the backend started to work as expected once more. This tells us that ONLY fallback cache is working and its also buggy.

    – Fallback cache is not buggy. If you have too many pages on your site or your server has low resource, then fallback cache will be generated for all those pages and maybe that’s what you are feeling. But I have need seen any such issues on any sites except big sites with many pages in which case I always recommend to not use fallback cache.

    So I put the following rule only to failsafe and pray to work.
    prevent the following URIs to be cached: /wp-admin*

    – This is not needed as the plugin automatically will takes care of that.
    If you just have this rule and no other rule then none of your HTML pages will get cached at Cloudflare CDN and only the static files will.

    Anyways 2500K users per day are not small traffic. Do you have any workers or stuffs in your cloudflare account? As cache is not supposed to expire that fast. Something else might be gong on in your CF account which is hard to tell without looking at it.

    Thread Starter diriras

    (@diriras)

    Hello,

    Thanks for the info you provided.

    No I don’t have any workers running, so to test it, I upgraded to the Cloudflare Pro plan, and now the plugin is working as it should for now, it keeps the pages cached without failsafe on.

    I will keep it pro for a month and I will return for a feedback when this ends!

    Regards,

    Michael

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Maybe Pro accounts have higher priority in file caching than free accounts.
    OK. Looking forward to hearing from you.

    Hello,

    I’m in the same situation as @diriras, which is why I came to the support group. I have tried all of the above (I’ve read the entire thread). I have CF Pro enabled for 30 days now, and nothing has changed. So when I post a new article, ALL pages in the cache are purged, defeating the plugin’s purpose.

    The only difference in my setup compared to @diriras is that I have a worker to locally handle fonts (you can find the script here: https://github.com/cloudflare/worker-examples/tree/master/examples/fast-google-fonts), but I still have the same issue as @diriras.

    Regards,
    Manos

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Hi @mpompas,
    Can you just try disabling the worker and also make sure that tired cache is enabled in your CF account and then test? Let me know what you find.

    Hi @isaumya

    Tired Cache has been enabled since day one (and it still is). As already mentioned by @diriras enabling the option “Disable cache purging using queue” seems to keep the cache; however, it doesn’t purge the cache on paginated pages (e.g.,/page/2/, /page/3/ etc.).

    Disabling the worker did not make a difference since when I posted a new article and tested it was disabled.

    Cheers,
    Manos

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Hi @mpompas,
    Sorry I don’t get your issue clearly. Can you please open a new thread with your issues clearly mentioned?
    If you question is related to when you publish a new post or update it and the related pages gets auto purged but the category page pagination does not get auto purged, then make sure that inside the plugin settings Posts Per Page section (https://i.imgur.com/ciZ047p.png) has the number mentioned as the number of posts shows up under each pagination page.

    Also, the system will only purge maximum of 10 paginated pages not beyond that.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Cached HTML pages showed cf-cache-status: MISS’ is closed to new replies.