Support » Plugin: WP-Optimize - Cache, Clean, Compress. » cache/wpo-minify

  • Resolved schuerich

    (@schuerich)


    It’s a very good plugin, but it has 1 huge drawback. In the cache / wpo-minify folder it generates a lot of folders that cause a dynamic increase in the folder size and even its overload. Folders do not delete automatically, they are growing at an exponential rate and this is also important because after a few days when you do a backup, you find that the backup is 1 GB instead of 300 MB. When you delete files in the cache / wpo-minify folder via FTP, the backup is again 300 MB, but you have to do it manually.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Harshad

    (@bornforphp)

    @schuerich You can set the cache lifespan upto 24 hours or less in WP-Optimize > Cache > Cache settings, so the cache files will get automatically deleted after set interval.

    Plugin Support Harshad

    (@bornforphp)

    @schuerich Please discard my previous reply I’ve misread that you are having issues with cache files.

    Please use the following method instead

    In order to purge everything, you can go to Minify > Advanced and turn on “Enable debug mode”.

    Then in Minify status, you’ll have a “Delete all the files generated by minify”.
    This should purge everything.

    Note that these files get purged automatically after 30 days (which is why the button is not always visible).

    You can use the following snippet, please add it to your active theme’s functions.php file to change the lifespan upto 7 days.

    
    add_filter( 'wp_optimize_minify_cache_expiry_time', function( $original_value ) {
    	return time() - 86400 * 7;
    } );
    Thread Starter schuerich

    (@schuerich)

    This is not a solution! For a year, I was almost convinced that when I pressed the “Reset the minified files” or “Purge cache” button, all the unnecessary files were deleted. Now it turns out that it is not so.

    Should I log into FTP and edit PHP files every 3-4 days? What if I have 40 or 50 pages? The example I have given is authentic. Within 3-4 days WP Optimize can make an installation with 300 MB into one with 1000 MB!

    Not everybody has large server, not everybody has unlimited traffic, and not everybody knows about it! What I discovered is a problem that will shock a lot of people – a real problem and your solution to the problem does not solve anything.

    Plugin Support Marc Lacroix

    (@marcusig)

    Hi @schuerich

    Thank you for your feedback. We’ll look into a better solution to this issue.

    Though the answer above provides a way to delete everything without having to use FTP.

    The reason for keeping older files for a period of time is that many people use other page cacheing plugins or solutions, which might not interact with WP-Optimize.

    If the old minified files are deleted, this could result in breaking those cached pages.

    Should I log into FTP and edit PHP files every 3-4 days?

    The code snippet above only has to be entered once in a theme’s functions.php or a small plugin, IF you don’t want to enable debug mode in order to show the purge button, but instead change the lifespan of the old minified cache. So no matter if you have hundreds of pages, you only have to do it once.

    This being said, if the folder cache/wpo-minify is 700MB, you may want to check what’s being cached in WP-OPtimize > Minify > Advanced > List of processed files, as it seems more than it should.

    For example on https://updraftplus.com/, which has 500+ posts, 100 pages, and a forum with thousands of topics, the total cache is currently under 200MB.

    What is the typical size displayed in your settings?
    e.g.

    Marc

    Hi @marcusig

    I just encountered similar issue as OP ( @schuerich ) as well – but in my case the # files / file size grown into a scary number causing my EBS volume to be maxed out.

    https://pictr.com/image/7vyzfO

    For troubleshooting purposes, my website only has:
    – 12 posts
    – 10 pages
    – ~10K unique visitors monthly

    As interim I went ahead to enable DEBUG mode to manually “Delete all the files generated by minify”

    I am getting the same issue. After I installed the wp-optimize plugin lots of files of “/wpo-minify/161972458/assets/” type started creating.I have set the cache removal for 0 hours and still, they are not flushing and I have to manually do them every time. These files started affecting my core web vitals too and they are creating mobile issues. In just half an hour, around 200 such files stack up. How to get rid of these files I have set all the limits to a minimum but still, they are coming again and again. If the issue persists I have to unfortunately delete the plugin.

    • This reply was modified 3 days, 14 hours ago by apoorv9669. Reason: wanted to tick on "Notify me of follow-up replies via email"
Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.