Support » Plugin: Autoptimize » Cache Sizes go up to 100s of MBs Without Easy Solution

  • My cache size kept going up to 100s of MBs and finding a solution is not straightforward. Even after reviewing the FAQs, I should not have to install another plugin to solve this plugin’s problems or implement another piece of code to solve the caching issue, as described in the FAQ solution.

    I’m sure this plugin offers a great solution for some websites, but it’s not easy to use in my opinion and the large caching problem happened to me on multiple projects.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    Definitely don’t waste your time.

    I’ll ask that other half a million users to uninstall then 😉

    there is no way to prevent it

    Did you have a look at the FAQ for info on the topic? What did you try to do to prevent it?

    Because I’m actually prepared to bet a substanial amount of money that this can be prevented @brandonfire 🙂

    have a nice day,
    frank

    Why do the 100s of other caching plugins available not have this problem?

    There’s no way to easily prevent it – The point is this is something super simple and shouldn’t be a pain to resolve with custom code.

    I did go through your FAQs – this problem shouldn’t even be one of them.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    Because AO is not a (page) caching plugin, it aggregates, minifies and caches the optimized CSS & JS. As explained in the FAQ automatically purging items from AO’s cache would risk breaking the site, as cached paged might have references to the deleted autoptimized CSS/ JS. Hence the importance of configuring AO to avoid the cache from “exploding” (and also because cache size issues hide other more important problems).

    Start by disabling “also aggregate inline JS”, if still growing fast also disable “also aggregate inline CSS” and for some themes (which link to page-specific CSS) you might also have to add wp-content/cache and/ or wp-content/uploads to the comma-separated CSS optimization exclusion list. That should cover 99,9% of all cache size problems. The remaining 0,1% we can discuss here (or better still in the support forum) 🙂

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    hey, you edited your response 🙂

    There’s no way to easily prevent it – The point is this is something super simple and shouldn’t be a pain to resolve with custom code.

    Custom code? There’s no mention of custom code to fix the cache-size thing in the FAQ @bernst2008 🙂

    As I wrote:

    1. Start by disabling “also aggregate inline JS”
    2. if cache size is still growing fast also disable “also aggregate inline CSS”
    3. for some themes (which link to page-specific CSS) you might also have to add wp-content/cache and/ or wp-content/uploads to the comma-separated CSS optimization exclusion list (I’ll admit, this one is not in the FAQ yet, themes doing this a rather new evolution)

    Seems pretty easy to me. And then off course there’s my great support and my sunny personality, what more would you want from a one-star plugin 😉

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    Don’t get me wrong, you’re entirely entitled to your opinion and if you think a 1-star is deserved, then by all means. It’s just that the title of your review is simply not correct because there is a resolution, even if you choose not to go down that road. Guess that is what’s bugging me here 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Cache Sizes go up to 100s of MBs Without Easy Solution’ is closed to new replies.