Support » Plugin: Proxy Cache Purge » Cache Service not working on dreampress with woocommerce

  • Resolved touficmamdouh

    (@touficmamdouh)


    i have woocommerce site with wpml multi lang cache service is not working im on Dreampress plus now load time Slow first byet get 2.5 second !!
    you can see in screen :
    https://ibb.co/pJvSj08
    https://ibb.co/Jn9GvK2
    need some help to fix that
    Tech information form check plugin
    Cache Service Nginx caching service is running but is unable to cache your site.
    Remote IP Your Nginx Proxy is set up correctly.
    Age Headers Your site is returning proper “Age” headers.
    Cookies Found Cookies have been detected. Unless your caching service is configured properly for the specific cookies, it may not cache properly. Please contact your webhost or administrator with information about the cookies found.

    Plugin Check No installed plugins were found on the known conflicts list.
    Theme Check No installed themes were found on the known conflicts list.
    Technical Details
    Server: openresty
    Date: Mon, 04 Feb 2019 01:19:30 GMT
    Content-type: text/html; charset=UTF-8
    Vary: Accept-Encoding
    Set-cookie: woocommerce_current_currency=; expires=Mon, 11-Feb-2019 01:19:30 GMT; Max-Age=604800; path=/
    Link: ; rel=shortlink
    X-varnish: MISS
    Age: Mon, 04 Feb 2019 01:19:28 GMT
    Content-encoding: gzip

    • This topic was modified 4 months, 1 week ago by  touficmamdouh.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    The plugin doesn’t do any caching for you. As indicated in the documentation, the plugin tells your cache service when to delete cached data, nothing more.

    I don’t offer diagnostics on everything here, since it’s just impossible, but I will point out the page told you what was wrong:

    Cookies Found Cookies have been detected. Unless your caching service is configured properly for the specific cookies, it may not cache properly. Please contact your webhost or administrator with information about the cookies found.

    And this:

    Set-cookie: woocommerce_current_currency=; expires=Mon, 11-Feb-2019 01:19:30 GMT; Max-Age=604800; path=/

    So your problem is that woocommerce_current_currency is being set on every page load, which tells your cache service not to cache. That should not be set unless the user has done something to tell the site what their currency is, so you would need to investigate when and why that’s being set all the time for everyone.

    im slove this in theme have some function to include woocommerce_current_currency widget in i remove that work fine last more this check with https://isvarnishworking.uk/
    see : Fail…ish! We detected Varnish on that domain, but the content doesn’t appear to be cached. Best check your configuration.

    and in plugin can check for x-varnish: HIT
    that mean is varnish working??

    200: OK
    server: openresty
    date: Mon, 04 Feb 2019 02:20:08 GMT
    content-type: text/html; charset=UTF-8
    transfer-encoding: chunked
    connection: close
    vary: Accept-Encoding
    link: ; rel=shortlink
    x-varnish: HIT
    age: Mon, 04 Feb 2019 02:18:30 GMT

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.