Support » Plugin: Cache Enabler - WordPress Cache » Cache problem

  • I do have problem with the cache enabler. I use it with cdn enabler, keycdn, optimus and fast velocity minify.
    The problem with the website is there is there is a separate login page and once a user is logged in, it redirect to profile page.however if a user clicks on home page, it shows homepage as if there was no previous log in. This usually continues for a while but eventually when loggedin user click homepage, it will show user logged in.
    Why the lag.
    The problem can be prevented alltogether if i exclude main page from being cached via cache enabler. This leads to website to being slower to load.
    Is there a way to prevent the lag that happens when a user has just logged in without excluding main page.
    Website is already fast without excluding any page.
    However the initial lag will cause confusion for a user
    This is my dilemma, do i need to exclude any cookie?
    Please i need your help

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Do you have anything defined in the “Regexp matching cookies that should cause the cache to be bypassed.” section of Cache Enabler’s settings? The default settings should bypass Cache Enabler’s cache for anyone logged in.

    Have you also tried disabling all other plugins to see if the issue is still reproducible?

    Nothing defined in the “Regexp matching cookies that should cause the cache to be bypassed.” no pages have been excluded.
    All the boxes in cache behaviour are ticked in cache enabler
    cache exclusions and cache inclusions left empty(default)
    I have tried to disabled plugins but the problem is still present. I even looked at developer tool in chrome. in body class logged-in not showing
    Other pages works fine and shows logged-in body class.

    I always sees below when the problem occurs. once it resolves after few minutes, it disappears.
    <!– Cache Enabler by KeyCDN @ 11.01.2019 11:12:44 (webp gzip) –>
    can i work around the problem without excluding home page from being cached. excluding page does reduce loading time.

    ”The default settings should bypass Cache Enabler’s cache for anyone logged in”
    The above does not happen for anyone logged in on home page. other pages are fine.

    Please what does this mean ‘ <!– Cache Enabler by KeyCDN @ 11.01.2019 11:12:44 (webp gzip) –> ‘

    The <!– Cache Enabler by KeyCDN @ 11.01.2019 11:12:44 (webp gzip) –> comment means that Cache Enabler is delivering a cached copy of the page.

    Are you able to provide me with the steps required to reproduce this issue? I will try to reproduce it on a test site.

    not much.
    step is straight forward. a new user registers on register page and then logs in. Clicking any links will show user still logged in. However clicking home page will show used as if there was no login in the first instance
    Hope i have been able explain this.
    Let me know if you require more information.

    Sorry i meant user and not used.

    Do you happen to have any other sort of caching mechanism enabled on your server? It might also be helpful if I could try recreating the issue on your site however at the moment your registration captcha is broken.

    Not aware of any other cache being used. nginx cache never used.
    registration recaptcha has been corrected.
    using the following plugins to make site fast. cache enabler, fast velocity minify, optimus, cdn enabler and keycdn. Site seems fast.
    I would appreciate if you can reproduce the problem. just clear cache for the site and login. It would redirect to profile page. If the link to home page is clicked, it would show as if you never logged in.
    however other links would show that you are logged in.
    If i exclude home page (id 62) from being cached, site becomes slow.
    I noticed that on the home page,logged-in not in bodyclass when the problem happens.
    It tends to correct itself after a while but why does it happen a lot.
    Do i need to change settings in keycdn to correct this?

    The captcha is still throwing an error. Have you cleared the cache?

    The problem is present regardless of recaptcha. I have cleared cache.
    Have you tried it as well

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Cache problem’ is closed to new replies.