Cache problem (6 posts)

  1. ladylynn
    Posted 10 years ago #

    I added the Countdown Timer plugin to my blog today, then because it extended beyond my sidebar, I pulled the coding back out of my sidebar. My problem is it's still showing up.

    I know it's not a browser cache problem because I've checked it in two seperate browsers and two seperate computers.

    Does WordPress cache pages? I remember a hack called WP-Cache, but I don't know if I re-added it after upgrading to WP 2.0.

    Does anybody have any suggestions for fixing this or can you point me in the right direction? I tried to do a search, and although I've been reading posts for the past couple hours I haven't come up with anything. Any help is appreciated.

    ETA: I should also say that I've tried completely deleting my sidebar php file and reloading it without the coding, but nothing changes. I also tried editing the sidebar php from the Theme Editor. In Theme Editor, it shows the coding is not there, yet I pull up my page and there it is!

    Also, when I complete deleted the sidebar php file and loaded my page, it still loaded like the file was there.

  2. Austin Matzko
    Posted 10 years ago #

    WP 2.0 does cache database requests, so I wouldn't expect it to do what you describe. However, you can empty the cache by deleting the "cache" folder under /wp-content, and WordPress should create a new one with fresh data.

  3. kri
    Posted 10 years ago #

    I see nothing of what you're talking about. I know this sounds annoying and stupid, but are you SURE it's not a cache problem? Have you tried loading the page in your browser, then hitting ctrl+F5? That will force a fresh load of the page.

  4. ladylynn
    Posted 10 years ago #

    Thanks filosofo. I tried that and it didn't make any difference. I finally just uploaded a renamed file for my left sidebar and changed the call in my index.php. Seems to be okay now.

    EDIT: Sorry kri...didn't see your post. It can't be a browser cache problem unless my laptop and the home computer in the kitchen both use the same cache.

    But yeah, I did try the CTRL+F5 and cleaned out both FF and IE's cache and history. Didn't make a difference.

    For some reason, the programming has my original sidebar file stored with that plugin's coding.

  5. davidchait
    Posted 10 years ago #

    It sounds like you added it to sidebar.php in a different theme from the one you are now editing/deleting files in... Double check what the active theme is, and that you don't have WP-Cache there and active...


  6. ladylynn
    Posted 10 years ago #

    Thanks for the response, David.

    I was definitely working with the correct theme. I only have three themes uploaded: the two that came with WP and the one I use. The file I was actually working with was leftcolumn.php, and in both the program I work in and WP's Theme Editor, the file showed the code wasn't there, but it still showed up when my blog was loaded.

    I ended up changing the filename to leftcolumna.php and made the necessary alterations in my index.php, single.php, and archive.php, and suddenly everything looked right.

    It blows my mind. I uploaded the identical file, just with a slight alteration in the name, and it made all the difference.

    I am still curious about what the problem was.

Topic Closed

This topic has been closed to new replies.

About this Topic