Support » Plugin: Swift Performance Lite » Cache pre-build fails due to SSL certificate problem

  • I can’t get cache pre-building to work at all because the page “get” fails due to
    “cURL error 60: SSL certificate problem: unable to get local issuer certificate”.

    The site is using Let’s Encrypt SSL. Has anybody got this working, or know of a solution? Presumably I either need to force curl to ignore the certificate, or get the necessary key data into the ca-bundle.crt file – but I’m out of my depth here.

    Thanks.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author swte

    (@swte)

    Can you send an URL pls?

    Thanks

    Sorry, I’ve currently removed the plugin. Don’t need it for a while as there’s still work to do on the site.

    I don’t think there’s any issue here related to your plugin – it’s a WP / server configuration problem that I need to sort out with my host when I have time!

    As far as I can see, you use the wp cron function to fetch pages to build & refresh the cache. The problem is that when wp uses curl to fetch the page, it’s unable to verify the ssl certificate, which is from Let’s Encrypt. So if I understand this, the PHP setup doesn’t have access to the necessary certificate info. As the wp installation, php and letsencrypt are all sourced from my hosting company (lcn.com), I’m hoping they can resolve it. But I’m too busy with other stuff this week – so hopefully next week.

    I’ll post any results here when I can. Meanwhile, any other suggestions would be most welcome – or corrections if my understanding is all wrong!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.