Support » Plugins » [Plugin: W3 Total Cache] Cache plugin slowing down site??? Please help.

  • Hi all,

    I am using W3 Total Cache, configured in the recommended way. I am using Cloudflare. I have optimised images. I have minified code. My google page speed score is 92…

    BUT when I’m not logged in my site,, takes ages to load! When logged in, it’s fine. Could it be the caching that’s causing the problem? My pingdom page score is 84/100, loading between 1 and 2 secs, but WebPagetest gives the figure for the first load at closer to 4 seconds and when I load it on my computer it takes ages (longer than 4 secs), when not logged in.

    When I load it, logged in, it’s lighting fast. But when I go to Chrome’s private browsing mode, where I’m not logged in, it takes ages to load, and the story is repeated if I change browser.

    Does anyone have any ideas as to what might be going wrong? Does the site take ages to load for you? I am a bit confused by the differences between the page speed metrics.

    Thanks in advance for your help.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Just a quick note that all of the different testing services will return different results, so they aren’t always going to give you the same score (all 88s, for example). They will also test for different things relative to the speed of your site & give you slightly different recommendations.

    Your site is loading slow for me right now. Did you turn on Minify at both W3TC and CloudFlare? If so, definitely make sure you’re only using one minify option on the site because having more than one can cause issues.

    Thanks very much. I did actually have three lots of minifying going on, so I’ve disabled two. That didn’t seem to make much difference to the speed, but I’ve also switched to the Google API to load jquery, which has knocked about half a second off.

    The problem is my ‘First Byte Time’. WebPagetest gives me As and Bs on all the other metrics, but D – F on that. What does that mean, and how can I fix it? I would have thought that was what Cloudflare would reduce… and I’m on a normal hosting package with Bluehost, so that shouldn’t be too slow either!


    CloudFlare wouldn’t really help with First Byte Time (we actually might make it look worse). Why this happens is here.

    “By definition cloudflare will add some first byte time since it needs to go back to your server and process the data but it should be minimal. My algorithm for calculating a first byte time grade doesn’t play nicely with something like cloudflare though so look at the before/after first byte times and compare those directly (doesn’t explain the one long time you had in a repeat view though).

    The algorithm for first byte time looks at the socket connect time to get an estimate of the round trip time to a server and then it uses a multiple of that as the baseline and adds 100ms for each letter.

    Since cloudflare has distributed edge nodes, they actually make your socket connect time a LOT faster than if the browser had to go back to the original server directly so the baseline is lowered. The actual request still needs to travel back to your server though so it can’t be any faster than it was before (and will usually be slightly slower). The effect that has is that it will lower the grade even if it is actually faster because the round trip time used for the baseline is faster. ”

    Try setting your W3TC page cache to disk <basic> rather than disk <enhanced>. I had the same issue.

    I’ll try it, but why will that help? What does it change?
    Thanks for the suggestion!

    I’m not sure actually. No on could answer my question, so I played with all the settings. I think it might have something to do with a setting on the host.

    changing from disk enhanced back to disk worked for me. thanks! i used to get an F with a first byte time of 1.2 seconds. now i get a B with around .5 seconds.

    i’m not sure does it have to do with location as well? if my server is in the east coast and i’m surfing in the west coast my byte time is slow >1 second
    my site is

    if it is the host server that is slow, what can i ask of them? my host is nexuses which has a lot of ram but I’m on a shared environment.

    toango, if you are on a shared host, I would also recommend disabling database caching as well.

    thanks. i turned off database caching and it actually made the site slower
    used to be .48seconds
    now .53 seconds
    also the repeat views are longer from 2seconds to 5.7 seconds
    is that normal or should i turn it back on?

    weird i turn database caching back on and now i’m getting a lower score affter clearing out all caches

    i get 1.043 seconds now. 🙁

    This is because your cache has been cleared and has to rebuild, I am assuming.
    Visit your page a couple of times, check other pages, then retest.

    Always use the same test location as well.

    re ran the test with database caching and getting a better score 🙂
    at .485 seconds

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: W3 Total Cache] Cache plugin slowing down site??? Please help.’ is closed to new replies.