Support » Plugin: Super Page Cache for Cloudflare » cache now isnt working?

  • diggerdogsausage

    (@diggerdogsausage)


    Hi
    The cache was working fine but now for some reason every page displays a miss for the cache and also doesnt display the response headers x-wp-cf-super-cache at all. Im kind of at a lose as to what might have changed. Do you have any ideas what i could check?
    Kind regards

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Mat

    (@mateithemeisle)

    Hello @diggerdogsausage ,

    Thank you for your reply!

    I have checked your website and I can see the correct headers being applied. (Screenshot)

    Are you still encountering issues?

    Thank you and have an amazing day!

    Thread Starter diggerdogsausage

    (@diggerdogsausage)

    Hi Mat
    Thanks for getting back so fast.
    I think maybe I am confusing myself. I was looking at the jpeg images which show a MISS. You are looking at the page (Kanko) and that shows HIT and that its being properly cached. Should I not be looking at the images and other individual files and just check the page base url?
    Kind regards

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Hi,
    I would suggest you to enable the option inside the plugin for adding cache for the static files (under the cache tab). It will then add the proper cache-control rules for the static files.

    Also I will recommend you to enable tired cache inside Cloudflare dashboard > Caching tab.

    Thread Starter diggerdogsausage

    (@diggerdogsausage)

    Hi,
    Ok thank you I understand now.
    I use Nginx on cloudways so I would need to add the re-write rule for that to work correctly is that right? I am not sure how to do that to be honest.
    Is there another plugin that works well alongside this that I could use just for the static file cache or do you think its fine just to leave that to Nginx?

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Yes if you are using nginx then the inside the plugin settings page it will show up the list of nginx rules that you need to add to your main nginx.conf file.

    Unfortunately, there is no easy plugin to do that as it is a server core file it needs to be modified manually. If you have managed hosting service then your hosting provider will help you with this.

    Thread Starter diggerdogsausage

    (@diggerdogsausage)

    Hi

    Do you have an FAQ or guide on adding this? I will also check with cloudways later to see if they can help with it.

    My question about another plugin was for the static file cache. Do you recommend adding a second plugin like wp super cache and just using it for static file cache or should I just let Nginx serve the static file cache?
    Kind regards

    Mat

    (@mateithemeisle)

    Hello @diggerdogsausage ,

    Thank you for the reply!

    You should not use any other caching system alongside WP Cloudflare Super Page Cache. Caching systems don’t work well together and if used at the same time, you might encounter issues.

    I would also suggest following @isaumya s advice and letting the server do the static file caching. You can access the rules that he was talking about by entering the Plugin Settings > Cache Tab > Search for Nginx instructions > CLick On “On this page” > Add those rules into the ngnix.conf file. (https://d.pr/nEXUvC)

    Everything should work as expected now.

    Thank you and have an amazing day!

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.