Support » Plugin: Quick Cache (Speed Without Compromise) » Cache not cleared when widgets are chnaged/new widgets are added

  • Hi,

    A wonderful plugin. But I have two small issues.

    1) I have activated quick cache. the cache time is of 7 days. All values are installation default except that I have enabled caching of querry strings as well. Now this small issue is, from my admin are if I add a new widget to my sidebar, it is visible from there, but if i open a seperate browser and access the site, the new widget is not available. I have to manually clear the cache, only then it becomes visible.

    2) I normally work with Iconic One (Child) theme and TwentyTwelve (Child) theme. Also at times, I work with generate press theme as well. But if I view the page source, the quick cache caching info is displayed only in Iconic one theme, not on other themes that I have mentioned.

    Why So???

    https://wordpress.org/plugins/quick-cache/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Raam Dev

    (@raamdev)

    But if I view the page source, the quick cache caching info is displayed only in Iconic one theme, not on other themes that I have mentioned.

    There are two possible reasons for this:

    • The other themes are setting the DONOTCACHEPAGE constant, telling caching plugins not to cache the page.
    • You have a plugin installed on the other sites that strips out all HTML comments from the page (CloudFlare with the “minify” option is known to do this). Quick Cache uses HTML Comments to leave notes about its current status, so if you have a plugin stripping out HTML Comments, then those notes will also get stripped out.

    from my admin are if I add a new widget to my sidebar, it is visible from there, but if i open a seperate browser and access the site, the new widget is not available. I have to manually clear the cache, only then it becomes visible.

    Right. When you make a change to your widgets, the cache must be cleared, otherwise the cache file that gets loaded will be a cache of the page before you added the widget.

    Yes…!!!! You got that exectly to the point… cloudflare’s minify is/was removing the html comments…!!! Thanks..!!!

    Right. When you make a change to your widgets, the cache must be cleared, otherwise the cache file that gets loaded will be a cache of the page before you added the widget.

    Ok so cache has to be cleared manually for the widgets to load…!! I was just trying to understand…. if i use a pro version of QC… Do I have to still have to do it manualy… or does it have some added features.. which takes care of some of this..????

    Plugin Author Raam Dev

    (@raamdev)

    Ok so cache has to be cleared manually for the widgets to load…!! I was just trying to understand…. if i use a pro version of QC… Do I have to still have to do it manualy… or does it have some added features.. which takes care of some of this..????

    Sorry, I misunderstood what you were doing. I just confirmed that this is actually a bug in Quick Cache: it should be automatically clearing the cache when you make changes to the widgets (in both the free and the Pro version).

    I’ve opened a bug report here: https://github.com/websharks/quick-cache/issues/411

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Cache not cleared when widgets are chnaged/new widgets are added’ is closed to new replies.