Support » Plugin: LiteSpeed Cache » Cache not cleared when editing plugin code

  • Resolved docjojo

    (@docjojo)


    Hello,

    I am working on the source code of a plugin, which is running on https://yogalehrer-coaching.de with current LiteSpeed Plugin installed and cache activated.

    Whenever I change some code within the plugin, I have to manully purge the cache – otherwise the changes will not be parsed into the site.

    Is there any setting that I need to configure, so that the cache software realizes the change in the source code?

    Regards, Chris

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Hai Zheng⚡

    (@hailite)

    Hi,

    To purge automatically, you can put the hook of the submission into Purge All Hooks in `Advanced’ tab.

    Thread Starter docjojo

    (@docjojo)

    Thank you for the super quick response.

    I have added ‘get_header’ and ‘wp_head’ which are used in the plugin.
    But no luck.
    Still have to manually purge.

    What am I doing wrong here?

    Regards Chris

    Plugin Support Hai Zheng⚡

    (@hailite)

    Well actually get_headers and wp_head are not the ones when you update the plugin.

    Can you tell which way you used to update codes? Better to check the target file in your submission form if you are editing from a form. Are you using WP’s plugins -> Editor?

    Thread Starter docjojo

    (@docjojo)

    I am using an FTP client to access the .php in my plugin-folder, edit the code in a local editor and safe the file via FTP.

    Plugin Support Hai Zheng⚡

    (@hailite)

    For that, I am afraid you have to manually purge. When you are in dev, you can consider to mark the pages you want to work on to no cache or disable cache temporarily.

    Maybe we can give an option in future some like disable cache for 1 hour?

    Thread Starter docjojo

    (@docjojo)

    How can I mark a page for LS-no-cache?
    Do you mean within .htaccess ?

    Regards, Chris

    Plugin Support Hai Zheng⚡

    (@hailite)

    In settings there is couple exclude from cache options you can use.

    Thread Starter docjojo

    (@docjojo)

    Ah, okay, thank you.
    Will use that.

    Besides, I like the LS cache and moved to an LSWS from apache.

    Regards, Chris

    Plugin Support Hai Zheng⚡

    (@hailite)

    Good to know. Enjoy!

    I will mark it as resolved. If you have any other issue, don’t hesitate to create a new one.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Cache not cleared when editing plugin code’ is closed to new replies.