Title: Cache Line 242 Error Message
Last modified: September 30, 2026

---

# Cache Line 242 Error Message

 *  Resolved [HKP](https://wordpress.org/support/users/hiskingdomprophecy/)
 * (@hiskingdomprophecy)
 * [14 hours, 29 minutes ago](https://wordpress.org/support/topic/cache-line-242-error-message/)
 * Hi Folks,
 * For the last few weeks I’ve been getting six of the following error messages 
   each time I save a post during editing or publishing.
 * `mod_fcgid: stderr: PHP Warning: Cannot use string as array in /home/xxx/wp-content/
   plugins/wp-optimize/cache/class-wpo-cache-rules.php on line 242, referer: https://
   xxx/wp-admin/post.php?post=317017&action=edit`
 * Can you possible give me some idea of where to look for a solution?
 * We have been struggling a lot recently with bots and trying various methods to
   stop them, and I guess that something has been added or changed and is causing
   this issue.
 * Regards and thanks,
   Angus

Viewing 2 replies - 1 through 2 (of 2 total)

 *  Plugin Support [jbgupdraft](https://wordpress.org/support/users/jbgupdraft/)
 * (@jbgupdraft)
 * [14 hours, 11 minutes ago](https://wordpress.org/support/topic/cache-line-242-error-message/#post-19033212)
 * Hi,
 * Thanks for reporting this! Our developers are aware of this issue and are actively
   working on a fix. When I was testing this issue previously I was only able to
   get it to show up in my logs when running PHP 8.5 but not on older versions.
 * Our development team will work on a fix and it will be released in an upcoming
   release of WP-Optimize.
 * Thanks!
 *  Thread Starter [HKP](https://wordpress.org/support/users/hiskingdomprophecy/)
 * (@hiskingdomprophecy)
 * [2 hours ago](https://wordpress.org/support/topic/cache-line-242-error-message/#post-19033623)
 * [@jbgupdraft](https://wordpress.org/support/users/jbgupdraft/)
   Thanks for the
   speedy response! Much appreciated!! Yes, I also have moved to 8.5 and I guess
   that is when I started to see these unusual Server Error Messages. The bots are
   causing so many of them that it is hard to recognise new ones, such as this one,
   when they arrive.The reason I moved from 8.3 to 8.4 was because the number of
   messages dropped hugely in that upgrade, and I was kinda hoping for the same 
   from 8.4 to 8.5… but sadly no, it has rather just seemed to have attracted them
   🙂 Ah well…. 🙂 Time will fix it……I shall mark this as resolved and await the
   update once your colleagues get around to finalizing it all.Regards and thanks,
   Angus

Viewing 2 replies - 1 through 2 (of 2 total)

You must be [logged in](https://login.wordpress.org/?redirect_to=https%3A%2F%2Fwordpress.org%2Fsupport%2Ftopic%2Fcache-line-242-error-message%2F%3Foutput_format%3Dmd&locale=en_US)
to reply to this topic.

 * ![](https://ps.w.org/wp-optimize/assets/icon-256x256.png?rev=1552899)
 * [WP-Optimize – Cache, Compress images, Minify & Clean database to boost page speed & performance](https://wordpress.org/plugins/wp-optimize/)
 * [Frequently Asked Questions](https://wordpress.org/plugins/wp-optimize/#faq)
 * [Support Threads](https://wordpress.org/support/plugin/wp-optimize/)
 * [Active Topics](https://wordpress.org/support/plugin/wp-optimize/active/)
 * [Unresolved Topics](https://wordpress.org/support/plugin/wp-optimize/unresolved/)
 * [Reviews](https://wordpress.org/support/plugin/wp-optimize/reviews/)

 * 2 replies
 * 2 participants
 * Last reply from: [HKP](https://wordpress.org/support/users/hiskingdomprophecy/)
 * Last activity: [2 hours ago](https://wordpress.org/support/topic/cache-line-242-error-message/#post-19033623)
 * Status: resolved