Support » Plugin: Autoptimize » Cache keeps growing (Yes I did read the faq)

  • Resolved baksteendegeweldige

    (@baksteendegeweldige)


    I have problems with the Autoptimize plugin.
    Yes, I did check the faq about this problem, but this issue is different!

    If I check Optimize HTML code and Optimize javascript code or optimize CSS code in the plugin settings, the autoptimize cache keeps on growing.
    If I only check Optimize HTML code the cache size is stable.

    It doesn’t matter if I only check HTML code and Optimize javascript code or Optimize HTML code and optimize CSS code.
    The cache keeps on growing.
    So there must be a JS AND CSS script that is causing this problem.

    I can’t find the script that is causing the problem, so I collected all the CSS file names that my site is using (google chrome ctrl-shift-j).
    I planned to add them all to the “Exclude CSS from Autoptimize” field and remove them one by one, so I could see which CSS file causes the problem.
    The problem is that the cache keeps on growing even if I add all the CSS files in the exclude list…
    Didn’t try this method yet with the js scripts

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    hey @baksteendegeweldige (toffe nickname);
    -> are your “also aggregate inline” (css & js) options on or off (off is better to battle cache size issues)?
    -> have a look at the number of files in wp-content/cache/autoptimize/css vs wp-content/cache/autoptimize/js, this will tell you if the problem is CSS or JS
    -> if CSS; Avada creates per-post style files like wp-content/uploads/fusion-styles/fusion-POSTID.css so excluding uploads/fusion-styles might be needed

    let me know what your find!

    groeten uit Lokeren!
    frank

    baksteendegeweldige

    (@baksteendegeweldige)

    Hello Frank,

    Thanks for your reply!

    -No, I don’t have the option “also aggregate inline” (CSS & js)” enabled.

    -The wp-content/cache/autoptimize/css, wp-content/cache/autoptimize/js is a good tip. It is a CSS problem. (For the moment I don’t have js optimization enabled, but still, it is a good tip to verify the CSS problem)

    -Yes, our theme is Avada, I already excluded fusion-11.css (https://www.lazertag.be/wp-content/uploads/fusion-styles/fusion-11.css?timestamp=1513579363&ver=4.9.1), so I think I don’t have to exclude the folder uploads/fusion-styles.

    -I found two CSS files that weren’t on our exclude list: front.css (layerslider plugin), wordfenceBox.css (wordfence plugin). I added them. I hope that one of these is causing the problem. I will let you know something tomorrow.

    Thanks for the great Plugin 🙂

    Groeten uit Leuven

    Martijn

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    based on what we saw, avada (can) create(s) multiple files in uploads/fusion-styles/, hence itt might be better to exclude that directory instead of the individual file.

    frank

    baksteendegeweldige

    (@baksteendegeweldige)

    Ok thanks.
    I excluded the directory.
    I will post an update tomorrow.

    baksteendegeweldige

    (@baksteendegeweldige)

    It works, the cache is stable if I add the following files / paths to the CSS exclude list:

    admin-bar.min.css, dashicons.min.css, fusion-11.css, go_pricing_skin_yellow.css, go_pricing_styles.css, jquery.fancybox-1.3.4.css, layerslider.css, quform.css, settings.css, style.css, style.min.css, wordfenceBox.css, front.css, adminbar-591.min.css, uploads/fusion-styles/

    So if you use the Avada theme exclude the path “uploads/fusion-styles/”.

    I added all the CSS files to the CSS exclude list on my site, now I will try the remove the the CSS files step by step from the list to see if the cache will stay stable.

    If I find another css file that belongs on the exclude list I will post an update.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Cache keeps growing (Yes I did read the faq)’ is closed to new replies.