Support » Plugin: NP Quote Request WooCommerce » Cache Issue caused by the plugin!

  • Resolved stavroscha

    (@stavrosomo)


    Hi there,

    The specific plugin is causing issues with the cache of WordPress website. Here is the exact error:

    x-proxy-cache-info: 0 NC:000000 UP:SKIP_CACHE_SET_COOKIE

    Can you please let me know if you have a quick fix for it or whether you are planning to release a new version for it that fixes this issue? I am asking because i do not want to waste more time and carry on with another way instead.

    Regards,
    Stav

Viewing 15 replies - 16 through 30 (of 30 total)
  • Thread Starter stavroscha

    (@stavrosomo)

    These are the settings i am using

    https://ibb.co/PFC8wkR

    Thread Starter stavroscha

    (@stavrosomo)

    I am using the RFQ and no i am not on Pantheon. Using Siteground for hosting

    Plugin Author Neah Plugins

    (@gplsaver)

    ok. let me check.

    Plugin Author Neah Plugins

    (@gplsaver)

    ok, i do see the cookie showed up again. i will remove it. give me a few minutes

    Plugin Author Neah Plugins

    (@gplsaver)

    OK. we found the issue. we will send an update shortly. when you update before using, right hand click on the secure page lock(ssl) and clear any cookie that starts with
    “rfqtk_wp_session_”. that will sit there for a while and then use it. from then on, you should only see the php session cookie PHPSESSID which should be OK.

    Plugin Author Neah Plugins

    (@gplsaver)

    OK. Try 1.9.1
    clear rfqtk_wp_session_ cookie first.

    Plugin Author Neah Plugins

    (@gplsaver)

    clear STYXKEY. there should not be a need for that with php sessions

    Plugin Author Neah Plugins

    (@gplsaver)

    Did it work?

    Thread Starter stavroscha

    (@stavrosomo)

    No it did not work. Still getting the same error

    Plugin Author Neah Plugins

    (@gplsaver)

    can you email us at contact@neahplugins.com?

    Plugin Author Neah Plugins

    (@gplsaver)

    Hi stavroscha,

    we actually created a site on siteground https://wptester.info/ to test your issue.

    you can check it yourself. it is a test site and in RFQ mode. we tested it in the following ways:

    turned on debug:
    1: RFQ checkout with both cookies and php sessions
    2: Normal checkout with both cookies and php sessions

    caching:
    Minify CSS Files enabled
    Combine CSS Files enabled
    Preload Combined CSS enabled

    caching Types
    Dynamic Caching enabled
    File-Based Caching enabled

    exclusions from cache : NONE. we purposely chose not to exclude anything

    we also uploaded about 30 misc plugin just to try to create a conflict.

    all the requests went through. we did get a few notices that i am printing here. just because it is a testing site.

    `[16-Feb-2022 21:05:08 UTC] PHP Notice: Undefined index: key in wptester.info/public_html/wp-content/plugins/woo-rfq-for-woocommerce/woo-rfq-includes/woo-rfq-functions.php on line 61
    [16-Feb-2022 21:05:09 UTC] PHP Notice: Undefined index: HTTP_HOST in wptester.info/public_html/wp-content/plugins/woo-rfq-for-woocommerce/woo-rfq-includes/woo-rfq-functions.php on line 57

    we have not been able to duplicate this problem on SiteGround ourselves or through other people who tested for us.

    this is a screen recording to see one of our tests.

    We definitely don’t want to deny your experience. we just can’t duplicate it in anyway.
    We are at a loss as to what this could be.

    Thread Starter stavroscha

    (@stavrosomo)

    thanks for looking into that further.

    there is no issue in the front end of the website and the request for quote works fine but the issue is when you try and manually purge cache and then check whether the website is cached or not through sg optimizer. Please find attached an image of it.

    https://ibb.co/bPkq04y

    Thread Starter stavroscha

    (@stavrosomo)

    The specific error appears when i press “test” button under “Test URL Caching Status”

    Plugin Author Neah Plugins

    (@gplsaver)

    we tested the way you described, with and without cookie, with and without exclusion
    and we only got the response

    Success URL is cached

    Plugin Author Neah Plugins

    (@gplsaver)

    not heard back. marked resolved

Viewing 15 replies - 16 through 30 (of 30 total)
  • You must be logged in to reply to this topic.