WordPress.org

Forums

All-in-One Event Calendar
cache fills up with +200MB files/day (16 posts)

  1. Yannick77
    Member
    Posted 1 year ago #

    I have an issue after updating to 1.10.11 since then all-in-one-event calendar is creating a lot of files in folder wp-content/plugins/all-in-one-event-calendar/cache

    more than 200MB per day!

    Most of the files have names like bellow - number changing at the end

    - c331dab8_ai1ec-response_agenda_standard_2014-03_34_39_46_45_54_51_50_37
    - c331dab8_ai1ec-response_agenda_jsonp_2014-03_45_34_54_50_37_51

    https://wordpress.org/plugins/all-in-one-event-calendar/

  2. Renaat
    Member
    Posted 1 year ago #

    I've got the same problem. The files are named like this one:
    46ff7e42_ai1ec-response_agenda_standard_2014-03_12_13_11_40_42_8_55

  3. repo0815
    Member
    Posted 1 year ago #

    I've got the same Problem like Renaat and Yannick77
    the Cache Folder has 120 MB
    any solutions?

  4. Yannick77
    Member
    Posted 1 year ago #

    Here the solution

    Go to the Advanced settings tab in Dashboard -> Events -> Settings.

    Check the value of Frequency of view cache purging: is set to something reasonable.

    Too small, and the cache will be ineffective (read: site will be slower if it gets accessed a lot). Too large, and you will end up with lots of files.

    3h is the default, but it may not have that value saved, so setting it to 2h isn't that much different, but should definitely set the value.

    source: http://community.time.ly/forum/troubleshooting/theme-and-plugin-conflicts_aa/9750-after-update-standard-all-in-one-event-calendar-cache-grows-data-200-mb-per-day

  5. Yannick77
    Member
    Posted 1 year ago #

    ps: deleting cache is ok

    (best download the cache folder to your PC for safety then delete cache if all works fine your ok :-)

  6. repo0815
    Member
    Posted 1 year ago #

    Thanks Yannick77 for the solution! :-)

  7. Jashan
    Member
    Posted 1 year ago #

    Hello Yannick,

    Thank you for the solution :)

    Take Care

  8. Renaat
    Member
    Posted 1 year ago #

    Hello Yannick,

    it doesn't seem to work for me. I use aioe-calendar on different sites with the same settings. On one of these sites it goes wrong. I've tried the solution but the advanced settings switch automatically in 3 hours, even when I set it to 1w or something like that. So every three days I have to get rid of 500 mb of cache. Do you know a solution?

    Thanks a lot!
    Renaat

  9. Yannick77
    Member
    Posted 1 year ago #

    I have put it on 1 h and it seems to work fine...

  10. Jashan
    Member
    Posted 1 year ago #

    Hello Renaat,

    You can turn off caching by going to wp-content -> plugins -> all in one calendar-> constants.php on line 503, set the AI1EC_CACHE to false

    Thanks

  11. Renaat
    Member
    Posted 1 year ago #

    Thanks,
    this works!

  12. Jashan
    Member
    Posted 1 year ago #

    Hello Yannick77,

    Please mark this as resolved :)

    Cheers!

  13. damiandodd
    Member
    Posted 1 year ago #

    I found out this plugin is generating thousands of cache files, which was maxing the I/O, CPU, and memory on my GoDaddy hosting. I'm currently deleting almost 100,000 files out of Cache. What the hell? Sounds like I should just turn caching off as indicated above. Someone tell me why caching on this plugin is a good thing? I know 2.0 is coming "soon" but I don't see where they are addressing this issue in the new version.

    I like this plugin. My clients like it. But I'm close to dropping it like a hot resource-hogging potato.

  14. Jashan
    Member
    Posted 1 year ago #

    Hello @damiandodd

    Go to the Advanced settings tab in Dashboard -> Events -> Settings.

    Check the value of Frequency of view cache purging: is set to something reasonable.

    Thanks

  15. damiandodd
    Member
    Posted 1 year ago #

    Could you elaborate on what "something reasonable" would mean? Or tell me would it cause any issues to turn caching off entirely? This plugin's caching has caused me at least 5 phone calls with GoDaddy while they tried to figure out what was maxing my files, I/O, Memory and CPU usage on my hosting. If default was 3 hours, this thread says to change to 2 hours. But does that mean it will generate 80,000 files instead of 100,000 files? I'm leaning toward 0 files.

  16. Jashan
    Member
    Posted 1 year ago #

    Hello

    In most of the cases, the reason of high memory usage is GOOGLE CRAWLING. Please read our article here on how to limit Google crawling: support.time.ly/limiting-excessive-google-crawls/

    Take care

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • All-in-One Event Calendar
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic