Support » Alpha/Beta/RC » Cache error?

  • surtin

    (@surtin)


    First off, hey everyone, love WP and these support forums are teh win. 😉

    Now on to business.

    Basically I’ve been testing the beta on my live blog since beta-1 (don’t really much care about random breakages and the like), the only real WP related problem I’ve had is the new caching system. It works and all but whenever I try to upgrade I have to go to wp-settings and comment out lines 65 and 66 so that my blog can be accessible.

    The error is as follows:
    Warning: main(/homepages/27/d89355863/htdocs/blog/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /homepages/27/d89355863/htdocs/blog/wp-settings.php on line 66

    Fatal error: main(): Failed opening required ‘/homepages/27/d89355863/htdocs/blog/wp-content/advanced-cache.php’ (include_path=’.:/usr/local/lib/php’) in /homepages/27/d89355863/htdocs/blog/wp-settings.php on line 66

    And here’s the offending (and surrounding lines):
    // For an advanced caching plugin to use, static because you would only want one
    if ( defined(‘WP_CACHE’) )
    require (ABSPATH . ‘wp-content/advanced-cache.php’);

    Like I said, after commenting out those 2 lines it seems like everything is working. The wp-content/cache folder is created and seems like it’s being updated as it should. Just to test things out I installed a fresh beta WP and never got that error at all. So I’m assuming something got borked when I first upgraded from 1.5.2 to the first beta.

    Oh well, my “fix” does the job for me, just figured I’d bring it to someones attention.

  • The topic ‘Cache error?’ is closed to new replies.