Support » Plugin: W3 Total Cache » Cache error

  • Resolved dionsis

    (@dionsis)


    I have a WP / Nginx setup

    I am getting this error
    3 Total Cache Error: Cache file /usr/share/nginx/html/wp-content/cache/config/master.php can’t be actualized. Remove it manually.minify.css.groups

    Any idea of what it is. I remove the file and save again and error persists.

    Lots of jetpack css / js is not getting minified so I assume this is related.

    http://wordpress.org/extend/plugins/w3-total-cache/

Viewing 9 replies - 1 through 9 (of 9 total)
  • This is in the nginx logs multiple times

    2013/06/26 02:39:11 [error] 18842#0: *104 FastCGI sent in stderr: “PHP message: PHP Warning: Missing argument 1 for W3_SharedRules::canonical_without_location(), called in /usr/share/nginx/html/wp-content/plugins/w3-total-cache/lib/W3/Dispatcher.php on line 132 and defined in /usr/share/nginx/html/wp-content/plugins/w3-total-cache/lib/W3/SharedRules.php on line 11” while reading upstream, client: 127.0.0.1, server: goldenplec.com, request: “GET /wp-admin/admin.php?page=w3tc_minify HTTP/1.1”, upstream: “fastcgi://127.0.0.1:9000”, host: “www.goldenplec.com”, referrer: “http://www.goldenplec.com/wp-admin/”

    Anyone else had this. Fredrick do you know what causes this error?

    I believe APC caused these problems

    It was preventing me from saving any data without restarting php-fpm and nginx.

    Hi I’m having this issue too, could you let me know how you fixed it:

    PHP Warning: Missing argument 1 for W3_SharedRules::canonical_without_location(), called in /var/www/html/myoverlandadventure/wp-content/plugins/w3-total-cache/lib/W3/Dispatcher.php on line 132 and defined in /var/www/html/myoverlandadventure/wp-content/plugins/w3-total-cache/lib/W3/SharedRules.php on line 11

    I’m having this issue as well…

    Warning: Missing argument 1 for W3_SharedRules::canonical_without_location(), called in /**/**/**/wp-content/plugins/w3-total-cache/lib/W3/Dispatcher.php on line 132 and defined in /**/**/**/wp-content/plugins/w3-total-cache/lib/W3/SharedRules.php on line 11

    I disabled APC.so from my php.ini

    I’m having the same issue as well.

    I’ve similar issue. The error message says:
    W3 Total Cache Error: Can’t read file /var/www/dws/wp-content/cache/config/master.php. Remove it manually.
    Any Idea why I’m getting this error? I’m also running into another issue with uploading files.It says “Image” has failed to upload due to an error
    Failed to write file to disk.
    I’ve verified that the Apache user has enough permissions and it was working fine last week. I believe nothing has changed since then but still I’m running into these two issues.
    Any help would be appreciated.

    We had to restart php-fpm to make that error go away.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Cache error’ is closed to new replies.