Support » Plugin: Cache Enabler » Cache Enabler Keeps Causing Fatal Errors

  • Hi folks,

    Since WP 5.6 I have been having problems which WP associate with the Cache Enabler plugin.

    Before that WP5.6 I could clear the cache(s) and there would be no issues.

    Since WP 5.6, when I click on “Clear Page Cache” or “Clear Site Cache” it will generate a WP Fatal Error message and email:

    “Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.
    In this case, WordPress caught an error with one of your plugins, Cache Enabler.”

    I also use the “Fast Velocity Minify” plugin and now I find that any changes I make to the settings in that plugin, on ‘save’, also result in a notification from WP that Cache Enabler has causes a Fatal Error for the site.

    This was not the case before WP 5.6.

    I thought when WP5.7 came along that the issue would be resolved by Cache Enabler or WP, but that seems not to have happened. So I write now to let you know.

    In the past I have turned on WP Debug to monitor the situation and see if I can get some error messages for you, but none is ever recorded, so I have no other information for you from that source. WP Debug just does not record any errors.

    Perhaps the server logs have such error data, but I don’t know what to look for, or where to look for it, or how to interpret such logs, so cannot provide it.

    However, I noted today that after a non-critical setting change on Fast Velocity Minify (which resulted in the above WP Fatal Error message), that the Cache Enabler cache was not cleared and the error seems to be limited to the admin side of the site, not to the public side.

    So, by the time I open a new browser tab, all was operational again immediately. Sometimes in the past it would take several seconds to get admin access again.

    I write to let you know.

    FYI, I like using Cache Enabler as it is both simple and effective and I have no intention of moving to another cache plugin. I just hope that this issue can get resolved sometime soon.

    Regards and thanks,
    Angus.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Corey

    (@coreyk)

    Based on what you’ve provided what you’re experiencing doesn’t sound like an issue directly related to Cache Enabler. I’m happy to look into this further to see if I can help identify why this is occurring. To begin, would it be possible to receive your Site Health Info? This can be obtained by going to your WordPress dashboard > Tools > Site Health > Info > Copy site info to clipboard.

    Thread Starter HisKingdomProphecy

    (@hiskingdomprophecy)

    @coreyk

    Thanks for your reply.

    The situation is still continuing, but I now notice it occurs when the CE Cache is larger, say over 300Mb. When the cache is small, there is no error message. The cache often reaches 1Gb. As I write it is 231Mb.

    My CE settings are Cache Expiry: 2hrs. and to “Clear the site cache if a plugin has been activated or deactivated.”

    Regards and thanks,
    Angus

    Site Health Info:

    
    ### wp-core ###
    
    version: 5.7.1
    site_language: en_US
    user_language: en_US
    timezone: Asia/Hong_Kong
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 108
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/hiskingd/domains/hiskingdomprophecy.com/private_html
    wordpress_size: loading...
    uploads_path: /home/hiskingd/domains/hiskingdomprophecy.com/private_html/wp-content/uploads
    uploads_size: loading...
    themes_path: /home/hiskingd/domains/hiskingdomprophecy.com/private_html/wp-content/themes
    themes_size: loading...
    plugins_path: /home/hiskingd/domains/hiskingdomprophecy.com/private_html/wp-content/plugins
    plugins_size: loading...
    database_size: loading...
    total_size: loading...
    
    ### wp-dropins (1) ###
    
    advanced-cache.php: true
    
    ### wp-active-theme ###
    
    name: Weaver Xtreme Child (weaver-xtreme-child)
    version: 4.2.6.1551866430
    author: Bruce Wampler
    author_website: //weavertheme.com/about
    parent_theme: Weaver Xtreme (weaver-xtreme)
    theme_features: core-block-patterns, automatic-feed-links, title-tag, post-thumbnails, customize-selective-refresh-widgets, html5, responsive-embeds, post-formats, wp-block-styles, align-wide, editor-styles, editor-style, custom-logo, custom-header, custom-background, menus, infinite-scroll, widgets
    theme_path: /home/hiskingd/domains/hiskingdomprophecy.com/private_html/wp-content/themes/weaver-xtreme-child
    auto_update: Disabled
    
    ### wp-parent-theme ###
    
    name: Weaver Xtreme (weaver-xtreme)
    version: 4.4.7
    author: Bruce Wampler
    author_website: //weavertheme.com/about
    theme_path: /home/hiskingd/domains/hiskingdomprophecy.com/private_html/wp-content/themes/weaver-xtreme
    auto_update: Disabled
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty-One: version: 1.3, author: the WordPress team, Auto-updates disabled
    
    ### wp-plugins-active (20) ###
    
    AddToAny Share Buttons: version: 1.7.44, author: AddToAny, Auto-updates enabled
    Advanced Editor Tools (previously TinyMCE Advanced): version: 5.6.0, author: Automattic, Auto-updates enabled
    All in One SEO: version: 4.1.0.2, author: All in One SEO Team, Auto-updates enabled
    Broken Link Checker: version: 1.11.15, author: WPMU DEV, Auto-updates enabled
    Cache Enabler: version: 1.7.1, author: KeyCDN, Auto-updates enabled
    Classic Editor: version: 1.6, author: WordPress Contributors, Auto-updates enabled
    Cloudinary: version: 2.7.1, author: Cloudinary Ltd., XWP, Auto-updates enabled
    Extra Sentence Space: version: 1.3.9, author: Scott Reilly, Auto-updates enabled
    Fast Secure Contact Form: version: 4.0.56, author: fastsecure, Auto-updates disabled
    Fast Velocity Minify: version: 3.1.7, author: Raul Peixoto, Auto-updates enabled
    GTranslate: version: 2.8.62, author: Translate AI Multilingual Solutions, Auto-updates enabled
    iThemes Security: version: 7.9.1, author: iThemes, Auto-updates enabled
    List category posts: version: 0.84.1, author: Fernando Briano, Auto-updates enabled
    Pre* Party Resource Hints: version: 1.7.6.3, author: Sam Perrow, Auto-updates enabled
    RefTagger: version: 2.4.1, author: Logos Bible Software, Auto-updates enabled
    UpdraftPlus - Backup/Restore: version: 1.16.55, author: UpdraftPlus.Com, DavidAnderson, Auto-updates enabled
    Virtual Robots.txt: version: 1.0.8, author: LittleBizzy, Auto-updates disabled
    Weaver Xtreme Theme Support: version: 4.4.5, author: wpweaver, Auto-updates enabled
    WPBruiser: version: 3.1.43, author: Mihai Chelaru, Auto-updates enabled
    XML Sitemap & Google News: version: 5.2.7, author: RavanH, Auto-updates enabled
    
    ### wp-plugins-inactive (6) ###
    
    Autoptimize: version: 2.8.3, author: Frank Goossens (futtta), Auto-updates disabled
    Better Search Replace: version: 1.3.4, author: Delicious Brains, Auto-updates enabled
    Easy Updates Manager: version: 9.0.8, author: Easy Updates Manager Team, Auto-updates disabled
    GTmetrix for WordPress: version: 0.4.4, author: GTmetrix, Auto-updates enabled
    Optimize Database after Deleting Revisions: version: 5.0.4, author: CAGE Web Design | Rolf van Gelder, Eindhoven, The Netherlands, Auto-updates disabled
    WP Rollback: version: 1.7.1, author: Impress.org, Auto-updates disabled
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1802
    imagemagick_version: ImageMagick 7.0.10-18 Q16 x86_64 2020-07-21 https://imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 64M
    upload_max_filesize: 64M
    max_effective_size: 64 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 8 GB
    	imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    	imagick::RESOURCETYPE_FILE: 49151
    	imagick::RESOURCETYPE_MAP: 8 GB
    	imagick::RESOURCETYPE_MEMORY: 4 GB
    	imagick::RESOURCETYPE_THREAD: 2
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: Linux 3.10.0 x86_64
    httpd_software: Apache/2
    php_version: 7.4.8 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    admin_memory_limit: 512M
    max_input_time: 60
    upload_max_filesize: 64M
    php_post_max_size: 64M
    curl_version: 7.29.0 NSS/3.34
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.4.13-MariaDB
    client_version: mysqlnd 7.4.8
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/hiskingd/domains/hiskingdomprophecy.com/private_html/wp-content
    WP_PLUGIN_DIR: /home/hiskingd/domains/hiskingdomprophecy.com/private_html/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    ### aioseo (2) ###
    
    noindexed: Search Page
    nofollowed: Attachments (attachment)
    
    
    Plugin Support Corey

    (@coreyk)

    Thanks for the additional information, @hiskingdomprophecy. Can you please try increasing your max_execution_time directive in your php.ini file? I’d recommend something like 180 or 300 instead of the default 30 in this case. (This value is defined in seconds.)

    Thread Starter HisKingdomProphecy

    (@hiskingdomprophecy)

    @coreyk

    Thanks. Have changed to 180.

    Will let you know what happens.

    Regards and thanks,
    Angus

    Thread Starter HisKingdomProphecy

    (@hiskingdomprophecy)

    @coreyk

    No difference.

    With max_execution_time = 180 and a 583 MB Cache Size, I still get a Fatal Error trying to “Clear Cite Cache” on the admin page.

    Regards and thanks,
    Angus

    Plugin Support Corey

    (@coreyk)

    Thanks for the confirmation. I presume the same would occur at 300 because it sounds like you’re not receiving an execution related error. Leaving this increased should at least resolve the issue that you reported in another thread related to the execution time.

    The bigger issue at hand could be related to your server’s memory. Is your allotted system memory exhausted when this issue occurs? Are you able to increase this to handle scanning your cache directory?

    Thread Starter HisKingdomProphecy

    (@hiskingdomprophecy)

    @coreyk

    Thanks. I agree with your thoughts and will leave the 300 for the time being.

    At the last WP Core update we got hit with 3x plugin issues which all manifested in greatly increased server loads: FYI, our current loading – during an off-peak time – is “load average: 24.06, 6.43, 3.60,” but plugins still worked.

    1 of the 3 plugina has already been updated and another is under final checking – but I know that one has an impact on our load averages of about 6x-9x the norm.

    As a result, I am a bit hesitant to change our server memory settings at the moment, as it may make matters worse overall.

    The good news is that at a quiet time just now, I manged to clear the CE cache – though it took a long time. So, progress has been made and I can now test the differences of including inline CSS and JavaScript.

    The other reason I am hesitant to change memory allocation settings is that this all worked 100% before this last WP Core update….. Therefore I do expect it all to work that way again soon, with the current server settings, once all the plugin issues are resolved.

    Corey, I’ll now wait patiently now and see what happens and let you know of any developments. Thanks for your help.

    Regards and thanks,
    Angus

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.