Support » Plugin: WP-Optimize - Clean, Compress, Cache. » Cache enabled, does nothing. How to debug?

  • Resolved parakeet

    (@parakeet)


    As per the title, I have enabled the plugin, and enabled caching.

    Unlike W3 Total Cache, which gave a noticeable speed bump, WP-Optimize appears to do absolutely nothing.

    How can I test for sure whether this is running properly?

    I’m sure it can’t be the case that it doesn’t work.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Marc Lacroix

    (@marcusig)

    Hi there,

    Sorry for the delay. When the cache works, there should be a comment at the bottom of the page, such as this:

    <!-- Cached by WP-Optimize (gzip) - https://getwpo.com - Last modified: Tue, 25 Feb 2020 15:48:48 GMT -->

    If it’s not there, you can either add define('WP_DEBUG', true); to wp-config.php, or add wpo_cache_debug=true to your url (e.g. mysite.com?wpo_cache_debug=true). This should allow showing a similar information as above, but with the reason for not caching.

    Marc.

    FYI, the mark-up contains…

    <!-- WP Optimize page cache - https://getwpo.com - page NOT cached because: User is logged in -->

    But “Serve cached pages to logged in users” is ticked in “Cache settings”.

    I presume this should mean, despite me being admin, I *should* be served a cached page/

    Plugin Support Marc Lacroix

    (@marcusig)

    > I presume this should mean, despite me being admin, I *should* be served a cached page/

    Yes that’s correct.

    But as you’re logged in, the page has to already exist in cache to be served from there (the cache is not created if the user is logged in).

    If the page is cached (to generate the cache, either visit the page using a non-logged in browser, or use the preloader) and it still does not serve the cached version, you may want to try to save the cache settings again, and maybe disable and re-enable caching, to make sure the configuration is writen correctly.

    Marc.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.