Support » Plugin: WP-Optimize - Cache, Clean, Compress. » Cache does not work and cannot deactivate or uninstall the plugin

  • Resolved pastillasparaadelgazar

    (@pastillasparaadelgazar)


    Hi,

    I am trying Wp optimize in my site and recently I activated the cache option. I am not using any other cache plugin in my site.

    I checked my pages and they were not cached and the cache directory was empty. Tried to deactivate cache and the plugin shows the Please wait… message forever and cannot deactivate the cache, I then try to deactivate the plugin and after a while the following error appears…

    Fatal error: Maximum execution time of 180 seconds exceeded in /home/wwwgwefit/public_html/wp-content/plugins/wp-optimize/cache/file-based-page-cache-functions.php on line 652

    So cache does not work, I cannot disable cache and I cannot deactivate the plugin. Can you tell me if there is a way to fix it or a way to uninstall it manually including any tables from the plugin in the database? Thanks.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author David Anderson

    (@davidanderson)

    Hi,

    Do you still have this problem if you update to the just-released version 3.0.10 ?

    Are you sure the cache directory is entry? The code reference in the message seems to indicate not. If you are using FTP to check, can you make sure your FTP client is configured to show “hidden” files?

    David

    Plugin Author David Anderson

    (@davidanderson)

    P.S. What method did you use to check if pages were being cached or not?

    If you turn WP_DEBUG on, it’s also possible to check why a page is not cached (a line is added at the bottom of the HTML source). Note that if you’re logged in, which presumably are, then you won’t see cached pages being served (on the default settings); you need to visit as a not-logged in visitor.

    Thread Starter pastillasparaadelgazar

    (@pastillasparaadelgazar)

    Hi,

    Thanks for your quick reply. I have just updated to latest version 3.0.10. and I still have the same problems:

    * I visit the site with different browser in which I am not logged in. I set the debug mode to true and efectively, no cache is being generated (cache directory empty and your cache info in purge section indicates 0 files). This error is shown in the page code: <!– WP Optimize page cache – https://getwpo.com – page not served from cache because: In the settings, caching is disabled for matches for one of the current request’s GET parameters –>

    It looks that as I have woocommerce set with geolocation compatible with cache that adds a parameter ?v=0b98720dcb2c to every page with my IP encoded.

    * Anyway, the main problems are that I cannot disable cache (Please wait…) stays forever and cache is not disabled and I cannot deactivate or uninstall the plugin. If I try to deactivate it now I get a 500 error.

    Please, I need step by step instructions to manually delete the plugin from server directory and database. Later I will install it for database optimization, but I will use another plugin for cache.

    Plugin Author David Anderson

    (@davidanderson)

    Thank you. WooCommerce deliberately adds that parameter for the purpose of cache-busting, i.e. preventing cacheing. It is the “Geolocation (with page cacheing support)” option; it “supports” page cacheing in the sense of it prevents it, which isn’t what most people expect. I believe we support it “natively”, without needing to use that option (i.e. can use the normal “Geolocation” option instead), but I will check that out.

    To prevent the plugin from attempting to empty the page cache upon plugin de-activation, add this to your theme’s functions.php file temporarily when you de-activate:

    add_filter('wpo_purge_page_cache_on_activate_deactivate_plugin', '__return_false');

    Are you able to inspect what is in the folder wp-content/cache/wpo-cache (and its subfolders?) The error message indicates it’s trying to delete something – and apparently it’s taking 3 minutes. This suggests either a gigantic quantity of contents, or a hard disk fault causing I/O timeouts that should be reported to the hosting company.

    Plugin Author David Anderson

    (@davidanderson)

    Another way to de-activate a plugin is to use FTP or your web hosting control panel to remove its directory (i.e. wp-content/plugins/wp-optimize), and then visit your “Plugins” page in the WP dashboard immediately after.

    Thread Starter pastillasparaadelgazar

    (@pastillasparaadelgazar)

    Hi,

    I have double checked every time and cache directory is totally empty.

    Adding that code to functions.php does not work. Cannot deactivate the plugin.

    On top of that, I cannot deactivate any plugin so WP Optimize is interfering with deactivate function somehow. When I try to deactiva WP Optimize OR any other plugin, I get the following error (even witht the functions.php code added).

    Fatal error: Maximum execution time of 180 seconds exceeded in /home/wwwgwefit/public_html/wp-content/plugins/wp-optimize/cache/file-based-page-cache-functions.php on line 652

    I am going to manually delete the plugin by FTP. Is there any tables in the database that I should delete from the plugin?

    Thread Starter pastillasparaadelgazar

    (@pastillasparaadelgazar)

    Extra info:

    After deleting manually the plugin by FTP, now I can deactivate any other plugin.

    Please, tell me if I have to delete any other directory created by the plugin (I see one /wp-content/wpo-cache) and any tables in the database to fully delete it.

    I will install it again clean for database optimization but not for cache.

    Plugin Author David Anderson

    (@davidanderson)

    There are no tables created by the plugin. wp-content/cache/wpo-cache is its only directory.

    WP-O’s page cache does seek to empty its cache if you deactivate a plugin, because plugins often have an effect on page content.

    If you have the problem on a site we can log into (don’t post credentials here), we’ve love to have a look – it’s a very weird problem. The line number is for a line that deletes a file found in the directory, but you’ve explained that there are no files in that directory… but apparently it’s taking 180 seconds to do that.

    Plugin Author David Anderson

    (@davidanderson)

    Hi,

    Upon further analysis of the data, we can now see how the timeout/loop can occur. It occurs if the filesystem call opendir() fails, even though the directory exists. This indicates perhaps some permissions issue, or a filesystem fault. We’ve tweaked our development version with a fix to handle this; therefore when 3.0.11 is released, if you upgrade, you will no longer have this problem. Thank you for your patience!

    David

    Thread Starter pastillasparaadelgazar

    (@pastillasparaadelgazar)

    Thanks for your help and I am happy I have provided some info to improve the plugin. For now I will only use it for database optimization. I also thought it was maybe caused by a permission issue because every single time I checked that the cache directory was empty.

    Thanks again 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Cache does not work and cannot deactivate or uninstall the plugin’ is closed to new replies.