Support » Plugin: LiteSpeed Cache » Cache-Control: no-store, no-cache, must-revalidate

  • Resolved adamngai

    (@adamngai)


    Hi Support Team,

    Report number: YABKFCHI
    Report date: 01/29/2019 05:28:34

    I have checked my site, seen like the lightspeed is not fully working because the status is… Cache-Control: no-store, no-cache, must-revalidate

    I have tried to search all related post but unable to find the correct way to solve it, hence I would like to seek for your professional advise for above status…

    Look forward to hearing from you soon.

    Thank you very much;
    Adam

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support stanley@litespeed

    (@stanleylitespeed)

    Hi @adamngai, your site’s response header is showing x-litespeed-cache: hit, it means your site is already cached by LiteSpeed. What do you mean by “not fully working”?

    adamngai

    (@adamngai)

    Hi Stanley,

    Greeting to you.

    https://openlitespeed.org/kb/how-to-setup-lscache-for-wordpress/

    I follow above link’s instruction that it mentions workable should be;
    -LiteSpeed-Cache: hit and X-LiteSpeed-Cache-Control: public,max-age=1800

    And if receiving the X-LiteSpeed-Cache: no-cache response header, it is likely that you are logged-in. Please log out and try refreshing the page again.

    The message that I obtains is Cache-Control: no-store, no-cache, must-revalidate, therefore I do not have idea is it in working status… 🙁

    The gtmatrix pagespeed score only 23%, is there any advise how to improve?

    Appreciate.

    TQ;
    Adam

    Plugin Support stanley@litespeed

    (@stanleylitespeed)

    Hi Adam, X-LiteSpeed-Cache-Control is different from Cache-Control, and I have checked the gtmatrix on your site, the major reason for the low score is Serve scaled images.

    You can resize all the images on your site to fit the screen width (just find the image under gtmatrix result > Serve scaled images and resize it one by one) and try to run LiteSpeed Cache Image Optimization to reduce the image size.

    Also, you should Defer parsing of JavaScript, you can do it by turn on LiteSpeed Cache > Optimization > Load JS Deferred and JS Combine. After you do all the operation please purge all cache and check the score again.

    Hi Stanley,

    I have used lscache media setting, and enable lazyload too, what I realize if I disable lazyload, my gtmatrix score very low, so I have choosed to enable. However, my site logo loading very slow till the end of loading, so I tried to put the path under Lazy Load Image Excludes, but look like it does not work at all, the placeholder grey colour still showing until the site almost loading finish the the logo appear, btw my logo size only 6k and 14k (retina).

    Any further advise?

    Thanks;
    Adam

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    May I know what URI you put in lazy exclude ?

    Best regards

    Hi qtwrk,

    /media/2019/01/logo.png
    /media/2019/01/logo_2x.png

    I have tried to just put single path as below but failed too…
    /media/2019/01

    Thanks;
    Adam

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    try “logo” , and please do remember purge all after you changed setting.

    Best regards,

    Hi qtwrk,

    Done, used the “logo” can settle…

    Thanks;
    Adam

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Cache-Control: no-store, no-cache, must-revalidate’ is closed to new replies.