Support » Plugin: GeoIP Detection » Cache

  • Hey, love the plugin, and I have a question regarding the caching.
    Is there a specific plugin script that I can add to exclude rules so its not cached instead of disabling the cache entirely?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Benjamin Pick

    (@benjaminpick)

    The plugin has an Web API-Cache (for Maxmind Precision, Hostinfo and Ipstack) – is this what you mean?

    Otherwise, I can’t help you as this depends on the page caching plugin you use. Normally you can define URLs that should be excluded in the cache etc. and maybe even this is not necessary as GeoIP already tries to tell the caching plugin to not cache as soon as it is used (if the “disable cache”-option is enabled), so pages that do not call the geoip-PHP-functions will still be cached..

    Hey Benjamin,

    Thank you for replying.
    I am using Contact Form 7 with GeoIP Detection on almost every page,
    and when the option to Disable Cache is enabled, no pages are cached.

    I am using WP Rocket, or Autoptimize (I have 2 different sites with the same question).

    What I meant in the question is: Is there a way just to exclude the GeoIP Detection from the cache, not the entire page.

    Usually what I do with the WP Rocket is, I exclude /wp-contet/some-plugin/(.*).js and it none of the plugin files are cached.
    But it did not work in this case.

    You might have to exclude /wp-content/some-plugin/ to Autoptimize’s comma-separated JS optimization exclusion list as well?

    frank (ao dev)

    Hey Frank,

    Tried that with the Autoptimize on one of the sites, and did not work,
    maybe the GeoIP Detection requires something different, that is why I asked for help here.

    Thank you for replying, btw.

    Plugin Author Benjamin Pick

    (@benjaminpick)

    Please show me a screenshot of your current options, otherwise it’s too much guesswork from my side.
    (JS caching should be no issue, try disabling HTML caching from Autoptimize to see if it is the JS or HTML.)

    try disabling HTML caching from Autoptimize

    AO does not cache HTML, it merely minifies it, leaving page caching to other plugins 🙂

    zeljkoilogic

    (@zeljkoilogic)

    Hey,

    All is good now with the Autoptimize, thank you for the help.

    This is the settings within the WP Rocket on the other site:
    https://prnt.sc/paphlz
    https://ibb.co/wrjy6w7

    Thanks again.

    Plugin Author Benjamin Pick

    (@benjaminpick)

    I still don’t know what exactly does not work – do you use the country selector for Contact Form 7 or only add the country to the email? Does the sending of the mail work?

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.