Support » Plugins and Hacks » [Resolved] By Custom Taxonomy 'Deleted 0 Post'

[Resolved] By Custom Taxonomy 'Deleted 0 Post'

  • Hi,

    I have the an issue when I trying to delete by custom taxonomy. Doesn’t matter I have 3 or 200 posts in it, any post isn’t deleted.

    I had no wait time after clicking in delete button, it sais me ‘Deleted 0 posts from the selected custom taxonomies’ inmediatly, no php errors or whatever.

    I can’t find out a solution for this. ┬┐Maybe my wordpress version (3.5.1 and plugin is latest version)?


Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author Sudar Muthu


    Is the custom taxonomy associated with normal posts or they are associated with custom post types?

    Also can you post all the options that you have selected and if possible a screenshot as well?

    Also can you try after disabling all other Pluigns?

    Is the custom taxonomy associated with normal posts or they are associated with custom post types?

    Yes it is, is associated to my custom post type ‘products’.

    Screenshot of my options here -> http://clip2net.com/s/5MTYlv

    I am not able to disable other plugins, I’m in a production enviroment of a client.

    After your questions, I figure out what the point is a problem with my custom post type, because with categorys and default posts pluggin works fine.

    Anyway, I don’t where exactly the problem is, maybe capabilitys of my custom post type? It has the same caps of a default post type.

    Plugin Author Sudar Muthu


    Yeah capabilities could be one problem. The other problem is plugins that override the where clause. (ie) have this in code add_filter( ‘pre_get_posts’ )

    Can you give me information about the following?

    • How is this custom post type and taxonomy created? Is it done by a Plugin or through custom code?
    • If you can’t disable the Plugins, then can you atleast give me the list of active Plugins?

    Created plugin through, could be a problem create it by code now, ’cause there’re post created already. (If it could be any fix)

    Plugin list part 1-> http://clip2net.com/s/5MVILA

    Plugin list part 2-> http://clip2net.com/s/5MVILA

    Plugin Author Sudar Muthu


    Both are the same images.

    Which plugin you used to create these custom taxonomies?

    Ups, excuse me

    Part 2-> http://clip2net.com/s/5MWcit

    The plugin used is Custom post type UI



    Hi, I appear to have the same problem. My custom post type is registered through a bespoke plugin – what capabilities do I have to enable? Thanks



    Hi jamesinealing,

    finally the problem wasn’ton the capabilities. For make plugin to work with custom post types and taxonomies you have to cutomize the plugins code.

    Plugins admin page gets your term taxonomy by name (value in the checkbox is the term name), and later in the query try to recover post to bo deleted by slug, so there’s no matches in that query.

    We have to modify this admin window, swaping terms checkboxes value for terms slug.

    While we have a new plugin version, you have to modify this by yourself. I hope it will help you.

    Plugin Author Sudar Muthu



    Now I know why it was not working earlier. In all my test cases, I was having both slug and term name same. But I guess if it is different, then the Plugin fails.

    Thanks for reporting this. I am currently working on a fix for this. You can track the progress here https://github.com/sudar/bulk-delete/issues/26

    Plugin Author Sudar Muthu


    I just released v4.0.2 of the Plugin with this fix.

    Kindly check the new version and let me know if you still face any issues.



    Just ran the install and gave it a quick test. Appeared to work a treat, so thanks so much for sorting this.

    One thing I did notice was that trying to delete all entries by selecting a category doesn’t work for and that were custom post types, which would be a nice feature to have.

    Plugin Author Sudar Muthu


    trying to delete all entries by selecting a category doesn’t work for and that were custom post types

    What is happening? Are you getting any error message? It should work.

    Hi Sudar, apologies for not getting back to you sooner. I have just been looking at this again and should explain the problem more clearly.

    I have a custom post type but I use the standard categories in my site. When I try to delete all the posts in the custom post type that match a particular category it appears to run but reports that no posts were deleted. I have just tried a further experiment though and created a test post as a normal blog post but assigned to the category that I am deleting. In this case when I run it it does delete that post, but not the ones in the custom post type. Does that make more sense? Can you think how this could be fixed?

    Just to follow up on this, I realised that it would be better anyway if I created a custom taxonomy that applied specifically to this Custom Post Type. But although I now have an option to delete *all* entries in that custom taxonomy, I don’t appear to just be able to delete just those with one value set, in the same way for example that I would be able to delete those posts matching one tag.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Resolved] By Custom Taxonomy 'Deleted 0 Post'’ is closed to new replies.