iThemes Security (formerly Better WP Security)
BWPS missing after update (2 posts)

  1. Meanderling
    Posted 1 year ago #

    Yesterday I got an 'unable to connect to database' error, couldn't get onto my site or admin (renamed plugins folder to disable, but no change) - gave up and went to bed. Today I can access the site/admin again (haven't done anything to cause or fix the error), when logging into admin I saw the notification that BWPS needed updating, which I instantly did - it showed the 'installing' message, but never progressed from that. I refreshed the page after about 10mins - the update notification is gone, but so is BWPS from my installed plugins. I've checked my server, the folder still exists, but it's empty except for the languages sub folder and content.

    Any idea what's going on - has my site been compromised? Should I go ahead and reinstall BWPS? What happened to my original install? ...and other questions of that ilk...

    Please help,

    Thanks :)


  2. Michele Butcher
    Posted 1 year ago #

    I believe that when you refreshed it for some reason was not done uploading and casued some of the plugin to not be installed. I have had this to happen with a different plugin. I would suggest delete the folder that still exists and reinstall BWPS. I do not believe that your site has been attacked while the download was happening. Weirder things have happened but the chances are slim.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic


No tags yet.