Support » Plugin: BackUpWordPress » BWP setting max_execution_time to 0 in backend?

  • Resolved beatR

    (@codepage)


    Hello
    this has blown my mind since yesterday:
    i try to install a new theme. the theme reports max_execution_time of 0, even though it’s set to 360.

    after lot of investigation and confusion (set value in frontend and everywhere else, 0 in backend of wordpress), i figured out that this has to do with BWP plugin.

    i understand you set it to 0, umlimited. altough i’m not certain this is a cool decision to make to just make new settings like this!

    support of the theme tells me, max_execution_time has to be higher than 0 for demo import to work. im just discussing with them that 0 means unlimited.

    but what is your feedback on the issue of setting ini values in the whole backend, not only when executing a backup?? (you have no idea how this warped my mind…)

    thanks!!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author katmoody

    (@katmoody)

    Hey there –

    The only php.ini values we change are changed within the backup directory and not to the rest of the website, so I’m not positive how that value would be set otherwise. Are you able to trace it otherwise? Perhaps at the wp-config.php level?

    Let me know as I haven’t seen this before 🙁

    Kat

    beatR

    (@codepage)

    Hi Kat

    i checked it out on another page and BWP definetly does set max_execution_time generally to 0. i installed phpinfo plugin, as soon as BWP is active, max_execution time 0.

    here is screenshot where you see the code that is running on every page in the backend and is setting the value to 0:
    http://wpretarget.codepage.net/bwp_timeout.png

    im not sure it’s a big deal. it just potentially opens up sites to infinite running loops on the server.

    Greets!

    Plugin Author katmoody

    (@katmoody)

    Woah – I totally missed that when I reviewed that same file looking for the max_execution_time and missed that the other constant would also change that variable! Now I feel horrible because I know I’ve told other people wrong before 😳

    Thank you for the screenshot and for telling me! I do think it’s something we should address in a more concrete way – I’m going to open a new issue up so we can explore it better.

    Thanks again and hope you’re set up for a great holiday season!

    Kat

    No worries!! 🙂

    And happy holidays too!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘BWP setting max_execution_time to 0 in backend?’ is closed to new replies.