Support » Plugin: Better WordPress Minify » BWM and WP Engine Compatibility

  • Hi,

    This might not be an issue with your plugin as much as my host. I’m using WP Engine and I’ve tried working with their support quite a bit, unfortunately we cannot get the “Friendly Minify Urls” feature to work. So I’m hoping that someone smarter than me has been able to figure this out and wouldn’t mind sharing.

    The problem is that the cached files are returning 404 errors. It looks like the plugin isn’t able to create the proper files in the cache directory (as it’s empty except for the .htaccess file).

    The weird part is that the staging area (WP Engine has a built in staging area) works just fine.

    Anyway, if you anyone has any experience with this I’d appreciate the help.

    Thanks,

    Jacob

    https://wordpress.org/plugins/bwp-minify/

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Khang Minh

    (@oddoneout)

    Is your wp-content folder writable? If so, try moving BWP Minify’s cache folder there, that might help.

    michael_compton

    (@michael_compton)

    Did this work? I’ve had the same issue, locally and on staging this plugin is great, but on production I get “400 bad request” on the minified files.

    Plugin Author Khang Minh

    (@oddoneout)

    What is the current document root? You can look for its value in BWP Minify > General Options > Minify Library Settings

    Thread Starter Jacob Wilson

    (@bjwilson22)

    Hey,

    Document root is:

    /nas/wp/www/sites/createak

    The folder was writable, but it still didn’t work. I ended up giving up and just hoping that someone else that uses WP Engine would be able to figure it out.

    Khang, I appreciate your response. Just so you know they are using a NGINX setup.

    Thanks,
    Jacob

    Plugin Author Khang Minh

    (@oddoneout)

    It’s working fine for me using nginx, so this must be some kind of misconfiguration when going from staging to live.

    @bjwilson22 I can try helping with this if you allow me. Also, since a .htaccess exist in the cache directory means that they only use nginx as a reverse proxy? Is it the same between staging and live?

    Mike Zielonka

    (@mikezielonka)

    I am having issues with WP Engine too.

    I have the rewrite rules enabled in .htaccess and in nginx (wp engine entered).

    I get 404’s anytime it’s enabled w/ CDN rewrite enabled.

    Plugin Author Khang Minh

    (@oddoneout)

    @mike Is there any chance to have your nginx.conf posted somewhere for me to see? You can send it to me via http://betterwp.net/contact/ as well.

    If CDN is not enabled, does the friendly minify url feature work?

    Thread Starter Jacob Wilson

    (@bjwilson22)

    My cdn was disabled at the time and it still didn’t work. I’ll work on getting the nginx.conf from them to post.

    You are right, it is a reverse proxy setup. If I remember right it did work on the staging site, just not the live version. Once they put the nginx rules back in I’ll play with it again.

    Thanks. Jacob

    Plugin Author Khang Minh

    (@oddoneout)

    @bjwilson22 what I want to make sure is staging and live have same nginx rules. Hopefully you can get the nginx.conf file.

    Mike Zielonka

    (@mikezielonka)

    I dont think WP Engine will be able to send this to us. :/

    sunnyt7

    (@sunnyt7)

    I’m having a similar issue.

    On my staging environment, everything works properly.

    On my live environment, I’m using a CDN, and am getting a 404 for the cached files. It does look like the friendly URLs are working though.

    Any way I could help?

    Plugin Author Khang Minh

    (@oddoneout)

    @sunnyt7 If you’re getting 404 for the cached files the friendly URLs should be broken as well. Would you mind contacting me via http://betterwp.net/contact/ ?

    sunnyt7

    (@sunnyt7)

    Sent ya a message. Let me know if you got it!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘BWM and WP Engine Compatibility’ is closed to new replies.