Support » Fixing WordPress » “Buy now” button wouldn’t work!!!

  • Dear support!
    I’m trying to activate “Buy now” button for Stripe for 4 days already, but nothing seams to be working for me. Although I copied and pasted all necessary keys correctly, and checked if everything active on my Stripe dashboard together with Stripe team support 10 times already, it still gives me warning in my wordpress admin panel,
    – “Stripe is in test mode however your test keys may not be valid. Test keys start with pk_test and sk_test or rk_test. Please go to your settings and, set your Stripe account keys.” I DID SET ACCOUNT KEYS THOUSAND TIMES ALREADY CORRECTLY!!
    When I go to my site to a problem (cart) page and do “Inspect elements” action, I see this ERROR: [Error] WebSocket connection to ‘wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data’ failed: Unexpected response code: 403
    It appeared after I updated woocommerce to a newest version as it was recommended, but “Buy now” button did not work before that as well.
    PLEASE HELP!!!!!

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi,

    You are using a premium theme. Did you tried discussing this issue with related support https://themeforest.net/item/flatsome-multipurpose-responsive-woocommerce-theme/5484319/support ?

    Regards

    The error you’re seeing appears to be related to Jetpack rather than Stripe, based on what I have read here:

    https://github.com/Automattic/pinghub/issues/8

    I’m not able to see that error when viewing the cart page so I believe that may be something you are only seeing when logged in. Someone in that thread recommended activating and deactivating Jetpack but I have not tried that so I can’t say if it will work. It was also mentioned that it isn’t a real fix, it will just eliminate the error. Automattic seems to be aware of and working on the issue already.

    As for your stripe configuration, I was able to submit a test order and pay via stripe with one of their test card numbers. If you are still seeing an error I believe you may need to clear your cache. Hopefully this helps!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘“Buy now” button wouldn’t work!!!’ is closed to new replies.