WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Buttons not working

[Resolved] Buttons not working

  • aaronkine
    Participant

    @aaronkin

    When I click on any of the buttons (Example: add file/folder buttons), it DOES add a ‘#’ to the URL but nothing happened.

    I installed JQuery to the latest version (jQuery Updater) and I dont get ANY errors in the Console but BuddyDrive still does not work.

    Chrome Console shows NO errors (using jQuery 2.0.3) BUT FireFox shows this error.

    Use of getPreventDefault() is deprecated. Use defaultPrevented instead.

    Any Ideas??

    http://wordpress.org/plugins/buddydrive/

Viewing 8 replies - 1 through 8 (of 8 total)
  • imath
    Participant

    @imath

    Hi,

    Yes.. I’ve already seen http://wordpress.org/support/topic/buddy-drive-not-working?replies=4#post-4904097

    I’ll see what i can do in next upgrade. Thanks for your feedback.

    imath
    Participant

    @imath

    I’m not ready yet to upgrade soon, so i’ve edited the 2 js files in the trunk of the plugin. If you wish, you can download the trunk version of the plugin to test if the things i’ve modified solves the problem on your website.

    You can download the trunk version (1.2-beta1) here :
    http://downloads.wordpress.org/plugin/buddydrive.zip

    Please, tell me wether it solves or not this issue.

    aaronkine
    Participant

    @aaronkin

    This did not resolve the issue. I have tried using Chrome Firefox and Safari.

    I’ve tried using Jquery 2.0.3 AND 1.10.2

    When i click any BuddyDrive button The Console Error shows the same error with both Jquery versions:
    Use of getPreventDefault() is deprecated. Use defaultPrevented instead.

    I also get this error when the page loads.
    Uncaught TypeError: Object [object Object] has no method ‘ns_mc_widget’ (index):873
    (anonymous function)

    Also this error when page loads:
    Uncaught TypeError: Cannot read property ‘currentStyle’ of null (plupload.js?ver=1.5.7:2)
    g.getStyle plupload.js?ver=1.5.7:2
    (anonymous function) plupload.html5.js?ver=1.5.7:1
    g.extend.trigger plupload.js?ver=1.5.7:2
    (anonymous function) plupload.js?ver=1.5.7:2
    l.runtimes.Html5.l.addRuntime.init plupload.html5.js?ver=1.5.7:1
    v plupload.js?ver=1.5.7:2
    g.extend.init plupload.js?ver=1.5.7:2
    WPUF_Obj.featImgUploader wpuf.js?ver=3.7.1:108
    WPUF_Obj.init wpuf.js?ver=3.7.1:14
    (anonymous function) wpuf.js?ver=3.7.1:213
    l jquery-2.0.3.min.js?ver=2.0.3:4
    c.fireWith jquery-2.0.3.min.js?ver=2.0.3:4
    x.extend.ready jquery-2.0.3.min.js?ver=2.0.3:4
    S

    imath
    Participant

    @imath

    Interesting. Can you try by deactivating the plugin jQuery updater please ?

    aaronkine
    Participant

    @aaronkin

    I deactivating the plugin jQuery updater and I get the same error.

    imath
    Participant

    @imath

    So the problem is elsewhere.

    You can try to activate the twentytwelve theme to see if it’s a js conflict with the theme.
    After that, i’m afraid the way to solve this is to deactivate plugins 1 by 1 to see if that changes anything..

    aaronkine
    Participant

    @aaronkin

    ok i found the plugin conflict. WP User Frontend. I just upgraded to the Premium (Pro) version of WP Frontend and the problem is still there.

    …BUT there is an option that i turned off and now BuddyDrive works…
    in the WPUF Settings I turned Off this setting “Load Script- Load scripts/styles in all pages”

    Now i’m curious what scripts are the conflict?

    I also posted this issue at WP User Frontend Support. I’ll post here if there is a solution/answer.

    imath
    Participant

    @imath

    Thanks a lot for your feedback, i’ll try to find some time checking why there is this conflict.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Buttons not working’ is closed to new replies.