Support » Plugin: Standout Color Boxes and Buttons » Buttons not working

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author jp2112


    You can see the buttons on my demo page:

    Standout Color Boxes and Buttons WordPress Plugin

    For color buttons, you must specify the URL, either in the shortcode or the plugin settings page.

    Please post the exact code you are using.

    I’m seeing the exact same thing. Color Boxes work, but not the Color Buttons. As the above poster, I copied/pasted your code (with url) into the page and it doesn’t show up

    Plugin Author jp2112


    Guys, meet me halfway on this one. Please post the settings from the plugins page and also the exact code you are using, and where you are putting it. Also it would help if you had a sample URL where the buttons are supposed to appear.


    Yes the button shortcode doesn’t seem to be working. I have the following implemented on a page.

    [color-button color=”orange” url=””]Transit: Pacific / 7th Tacoma-Downtown[/color-button]

    The HREF is shortened to in this example to show the intention of use. The actual long URL for the map for the link would be placed there. I have used both the long and shortened version of the URL–no luck. I have left the HREF blank and even “#” with no success. The button simply does not show up.

    It wasn’t until I added a default URL to the settings panel for the plugin, such as, the button appears regardless if their is something in the HREF reference or not. If you have a default URL, the default URL is the ONLY URL the shortcode will display.

    Your colored boxes work flawless. I am using your latest version of this plugin and WordPress 3.5.1.

    Reviewing the source code of the page, the shortcode does not add any HTML to the page when rendered if there is NO default URL set in the settings of the plugin.

    Plugin Author jp2112


    Thanks for reporting this. Let me look into it and get back to you.

    Plugin Author jp2112


    OK, figured it out.

    There is no issue with the plugin, but with the documentation. The parameter name for specifying a URL is “href”, not “url”. I am updating the readme file now. The correct parameter names are displayed on the plugin settings page, however.

    Change “url” to “href” in your code above and it should work.

    That fixed it. Thank you.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Buttons not working’ is closed to new replies.