Support » Plugin: Mobile Call Now & Map Buttons » Buttons not showing up on mobile

  • Resolved jswanny


    Hi David, I installed the plugin, but nothing shows up on my site…I have installed this successfully on other sites. Can you please assist. Thank you

    {“PHP”:”7.1.25″,”WordPress”:”5.0.2″,”Theme”:” (ekwa) “,”URL”:””,”Plugins”:[“all-in-one-wp-migration\/all-in-one-wp-migration.php”,”contact-form-7\/wp-contact-form-7.php”,”duracelltomi-google-tag-manager\/duracelltomi-google-tag-manager-for-wordpress.php”,”jonradio-shortcodes-anywhere-or-everywhere\/jonradio-shortcodes-anywhere-or-everywhere.php”,”loginizer\/loginizer.php”,”mobile-call-now-map-buttons\/roi-mobile-call-now-map-buttons.php”,”nelio-ab-testing\/nelio-ab-testing.php”,”redirection\/redirection.php”,”remove-category-url\/remove-category-url.php”,”sg-cachepress\/sg-cachepress.php”,”updraftplus\/updraftplus.php”,”wordfence\/wordfence.php”,”wordpress-seo\/wp-seo.php”,”wp-slick-slider-and-image-carousel\/wp-slick-image-slider.php”,”wp-super-cache\/wp-cache.php”,”yoast-seo-search-index-purge\/yoast-seo-search-index-purge.php”]}

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author David Sword



    So taking a look at the source code I see that the plugin isn’t even there. Usually the issue you described is a CSS issue. So this is a first.

    1) check that a phone number andor address have been entered and properly saved in the wp-admin > Settings > Mobile Call Now & Map Buttons page

    2) flush wp-super-cache, and any other caches your hosting provider may have

    3) ensure your active theme, in the footer.php file, has the wp_footer() function, this plugin outputs itself there.

    Please let me know how those three go and what you find out. If not success, I have a few more troubleshooting tips up my selves to resolve this.

    Thanks David, here is my footer.php file:

    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),

    ga(‘create’, ‘UA-79459137-20’, ‘auto’);
    ga(‘send’, ‘pageview’);

    <!–footer ends–>
    <div id=”fb-root”></div>
    <?php include(“includes/mobile-menu.html”);?>
    <script type=”text/javascript” src=””></script>
    <?php if(!$mobile):?>
    <!–[if gt IE 8]><!–>
    new WOW({ mobile: false}).init();
    <script type=”text/javascript” src=””></script>
    <script type=”text/javascript” src=”//″></script>
    <?php endif;?>

    I don’t see the wp_footer() function and would not know where to add it. Thanks for looking at this issue.

    Plugin Author David Sword


    Yeah, that would be why then. All WordPress themes should include it, it’s an important part of building a WordPress theme.

    To add this in, where it currently is


    change that to:

    <?php wp_footer(); ?>

    Marking as resolved, but please let me know how it works out.

    That worked 🙂 Thanks David!
    PS: I’m in Vernon (Coldstream) as well 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Buttons not showing up on mobile’ is closed to new replies.