• Resolved gutterboy333



    I am trying to update from another plugin, that being the old PayPal Gateway plugin by WooCommerce and am trying this one out, however am having some issues with the buttons.

    I have multiple payment options available and it seems to be not behaving correctly.

    PayPal is the default option selected, and it *should* just show the two custom PayPal buttons (standard + credit card), but it seems it ALSO doesn’t hide the default button that is used for the other payment options (of which don’t have their own custom payment buttons).

    When I change payment options, the two custom PayPal buttons don’t hide.

    You can see how it’s supposed to behave with the current plugin that is being used on the live site here:


    Also, some other issues:

    The current plugin I am using alerts you right away if you have failed to fill in any fields when attempting to open the PayPal window (such as not agreeing to the terms), but with this plugin I have noticed it allowed me to pay for the item without agreeing to the terms.

    Also, not a major issue, just an improvement.

    The current plugin I am using, when you open the PayPal window and then close it again, does nothing, just simply closes the window as expected, but with this one it reloads the page and states your “Order has been cancelled”, which isn’t really correct?


    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author WebToffee


    Hi @gutterboy333,

    Greetings from Webtoffee!

    There seems to be some misunderstanding on how the plugin works. The 2 extra buttons that you are referring to are Express Checkout buttons, which if you don’t need, you can disable in the checkout page from the plugin settings. It will show overall other payment gateways to provide the express checkout option.

    As for the other issue, this plugin too only closes the page and reloads the checkout or cart page.
    Please refer the screen recording: https://www.loom.com/share/47d9575a48494311a2690818588fdab7

    Thread Starter gutterboy333


    Hi there and thanks for the response.

    I have selected the “Smart buttons”, not the “Express” option, as I want the two custom buttons below, so the user stays within the site when they pay.

    With the current plugin, as stated, it has these two buttons, but hides the other button that is not needed. That’s the flow I want to retain.

    I checked your screen recording, but that is different to what I see. When I click the button I get a small popup window (not a new tab); when you close it, ideally it should not reload the page and tell you your order has been cancelled.

    Plugin Author WebToffee


    Hi @gutterboy333,

    Please add the below code snippet in the active theme’s functions.php file to hide the Paypal option on the checkout page and keep the express checkout options.

    function eh_woocommerce_available_payment_gateways($available_gateways) {
        return $available_gateways;
    add_filter( 'woocommerce_available_payment_gateways', 'eh_woocommerce_available_payment_gateways');
    Thread Starter gutterboy333


    Thank you for that; I will try it out in the future if need be, but for this one I had to use another plugin as I needed to get things moving.

    Thanks anyway for your help 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Buttons not displaying/hiding correctly’ is closed to new replies.