Support » Plugin: WordPress Button Plugin MaxButtons » Buttons no longer adapt the size to the screen of the mobile

  • Resolved Rodrigo

    (@vejapixel)


    Hello people,

    I realized today that on mobile the size of the button carries the same size defined on the desktop: https://prnt.sc/trfko7
    Before they were normal, but now the buttons no longer adapt to the size of the mobile screen.

    How to fix this?

    Thank you!

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Bas Schuiling

    (@basszje)

    Hi Rodrigo,

    Did you create a responsive screen for this button? That is the way to do it in the new version.

    Thread Starter Rodrigo

    (@vejapixel)

    Hello @basszje

    In the past there was a responsive option where when activating it, the button adapted perfectly to the mobile screen, but after updating the plugin, I no longer find this option.

    Plugin Author Bas Schuiling

    (@basszje)

    Hi,

    Before we had a very simple system in place that would always make the button 90% of the size, and also decrease the font a little bit. This was only in a few cases handy, but otherwise a very limited system. We might bring it back as a default now in an upcoming version since more people seem to be confused by this.

    You can add responsive styles to your button by adding a new screen ( the big Add button in top of the screen ) in the meanwhile.

    I am having the same problem.
    The button was perfectly responsive and now it’s not.
    This issue is costing me money by loss of sales.

    If I am going to have to go through all my buttons and set up a new responsive page I’m more likely to just delete the plugin and use the gutenberg default buttons.

    Thread Starter Rodrigo

    (@vejapixel)

    Hello @basszje

    I did the process to create a new screen, but nothing happened, that is, it didn’t create any screens. Watch a video I recorded: https://www.loom.com/share/8c51c9d755724c09ac0fa03147c4b377

    This new screen shows 4 screen options (modern, medium, small and old smartphone). If I want the button to be adaptable to any screen size and on any smartphone, then do I have to create 4 screens, one screen for each option?

    I think you could offer an option to just select an option and automatically the button is adaptable for smartphone screens, be it small, medium, large, it doesn’t matter because the button adapts automatically.

    Plugin Author Bas Schuiling

    (@basszje)

    @vejapixel You need to click the button ‘ save and add new screen ‘ in that dialog. That should work. You don’t have to define screens for all options. The presets are just a suggestion.

    You can easily target them all by settings the min and max width between 0 and 968 ( as example ) and them it will target all devices with those screen sizes.

    Version 8.1 brings back the autoresponsive option. It’s active by default if there are no responsive screens set on a button. You can turn it off in the settings if needed.

    Thread Starter Rodrigo

    (@vejapixel)

    Hi @basszje,

    I clicked on the “save and add new screen” button and now created the screen. However, I selected all the options and none of them work: https://prnt.sc/txy132 / https://prnt.sc/txy1fo

    Thread Starter Rodrigo

    (@vejapixel)

    I updated the plugin to version 8.1.1 and with the automatic responsive function enabled it is now working normally.

    You could give us the option to change the font on tablet and mobile screens: https://prnt.sc/txydlr
    The size of the button is automatically resized, so there is no need to adjust it, but sometimes the font size can be very small, so there could be an option to adjust the size.

    Plugin Author Bas Schuiling

    (@basszje)

    @vejapixel I can’t tell from the screenshots if it works or not. When creating a screen, you can change all the options on that screen for the responsive version, including the button sizes and font sizes.

    I have brought back the autoresponsive function, in all it’s limited forms, exactly as it was before for maximum consistency. The size of the button is not automatically resized, but put to 90% width by the plugin (same as font size).

    Anything else can be controlled much more finely in the new version.

    Thread Starter Rodrigo

    (@vejapixel)

    Ok @basszje, I’m using automatic resizing as it was before.

    The idea of ​​creating screens for mobile is good, it just isn’t working. I create the screen, change the font, the font size, color, anything else, and nothing works. Everything remains the same on the frontend.

    But the idea is a good one. It just needs to work. And it could also work in conjunction with the automatic resize function, that is, as many users must already have several buttons created, so, if you disable automatic resizing and have to create a mobile screen for each button, it is very laborious for many of these users, then, could keep automatic resizing enabled and when we want a different set up (font size, font type, color, …) we create a screen for that specific button.

    Plugin Author Bas Schuiling

    (@basszje)

    @vejapixel You are flushing the cache right?

    You are exactly describing how it all should work after the last update.

    If something doesn’t work ( which is possible, it’s a new system ) I need descriptions what it should do, links to website where I can check the output, if possible screenshots of the button editor with the settings etc. Then I can work on fixing any issues that stand out.

    Thread Starter Rodrigo

    (@vejapixel)

    Hello @basszje

    The font size, style, color and ect customizations work correctly, however, only if I don’t enter any values in the widths. If I enter a value (https://prnt.sc/tz0x5r), the customizations are lost, and the button returns to the default.

    And in the case of the width of the button, it is not adapting to the width of the screen. I enter width 700, 600, 500 px and it doesn’t work.

    I decided to enter the value of 200px in the “Minimum Width” field and the customizations worked. If I enter, for example, 500px, it doesn’t work. Strange that.

    However, the width does not decrease in any way. I clear the cache, but it doesn’t solve it.

    Where can I send the data for you to access and see what happens?

    Plugin Author Bas Schuiling

    (@basszje)

    You understand that the two boxes in the screenshot are defined *when* the screen rule is active . Those don’t *do* anything with the button width. Just to be clear.

    The button size can be changed on the same place as the main button.

    If things still don’t work you can dump your database table ( maxbuttonsv3 ) and send it to support [at] maxfoundry.com and we’ll look if we can find any bugs.

    Thread Starter Rodrigo

    (@vejapixel)

    I understand now how it works. I have to change this field: https://prnt.sc/tzrxz1

    I think that if the automatic resize option is enabled (https://prnt.sc/tzry94), there is no need to use these 2 https://prnt.sc/tzrxz1fields.
    However, if I don’t adjust these 2 fields, the button is bigger than the smatphone screen.

    • This reply was modified 11 months, 3 weeks ago by Rodrigo.
    Plugin Author Bas Schuiling

    (@basszje)

    Hi,

    Yes, the screen sizes on top define when the responsive option is available. For instance, you can find mobile viewport sizes and then decide which ones should be active for this specific button.

    So you can target for instance all devices under 480px width ( min width 0 , max width 480 ) , everything between 480 and 1024 ( min width 480, max width 1024 ) and so on.

    All the other options will then *only* be applied when a device matches this screen size. You can test this by entered ‘mobile mode’ in your browser. In most browsers this is F12 for developer mode, then CTRL-SHIFT-M for mobile mode.

    Based on your feedback and other, we’ll look into a way to make it a bit more natural to understand the interface ( thanks ) .

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Buttons no longer adapt the size to the screen of the mobile’ is closed to new replies.