• Resolved thevisas

    (@thevisas)


    Hi,
    For an unknown reason none of the buttons show up.
    It works OK in a local test environment, but does not work in production.

    I have tried to disable caching plugins and to bypass cloudflare, but none of these steps resolved the issue.

    It would be greatly appreciated if you could have a look and advise on possible resolution.

    Regards, Vitali.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • thevisas

    (@thevisas)

    Hi,

    The workaround has ben found. It appears that the Buttonizer plugin has a conflict with Baidu script. After removing this script all buttons are working.

    It would be appreciated if you can advise what, if anything, can to be done in order to have the plugin working with the Baidu script. Script code is below.
    <script>
    (function(){
    var bp = document.createElement(‘script’);
    var curProtocol = window.location.protocol.split(‘:’)[0];
    if (curProtocol === ‘https’) {
    bp.src = ‘https://zz.bdstatic.com/linksubmit/push.js&#8217;;
    }
    else {
    bp.src = ‘https://push.zhanzhang.baidu.com/push.js&#8217;;
    }
    var s = document.getElementsByTagName(“script”)[0];
    s.parentNode.insertBefore(bp, s);
    })();

    Regards, Vitali.

    Plugin Author Buttonizer

    (@buttonizer)

    Hi,

    Sorry for the late reply!

    Thanks for letting us know the source of the problem.

    Just to make sure we’re on the same page.
    Is the Baidu script a Userscript?

    thevisas

    (@thevisas)

    Hi,

    Thank you for your reply.

    The script is a kind of tracking script and is placed in the footer template of the theme.

    It is used to submit pages (when they are accessed) to the Baidu search engine. The reason for using this script is because Baidu does not work well with sitemaps over HTTPS.

    Regards, Vitali.

    Plugin Author Buttonizer

    (@buttonizer)

    Hi Thevisas,

    We’ve added the script to our development environment and couldn’t find any errors or problems.

    Did you add the script tags through a plugin or manually in the theme? As there is a header-footer plugin that can add script tags to the header and footer.

    If you’d like you can re-add the javascript code to your website, then we’ll take a look tomorrow to check what’s going wrong.

    thevisas

    (@thevisas)

    Hi,

    Thank you again for looking into the issue.

    The script is added by the theme. In theme admin there is an option to add tracking codes and that is where it was added before.

    After the script was removed and caches cleared, the buttonizer started working straight away. However, after adding the script back this morning, the problem can no longer be reproduced and buttonizer continues to work.

    I am not sure whether the sequence of events has anything to do with it, but for now everything is working. If possible, I’d like to keep this request open for 1-2 days and do further testing. If it continues to work, I will close this request.

    On another note, could you please advise if the plugin can work with Font Awesome v4.7 that is already part of the theme. If it does work with 4.7, is it possible to disable downloading of 4.3 files by the plugin.

    Thank you again for your help.

    Regards, Vitali.

    Plugin Author Buttonizer

    (@buttonizer)

    Hi Thevisas,

    Glad to hear it’s working for now!

    Thank you for trying to find the source of the problem for us.
    We very much appreciate it! 🙂

    Regarding the question about Font Awesome.
    I’ve asked our lead developer if it’s possible to disable FA 4.3.
    Unfortunately, it’s currently not possible to disable FA 4.3 without breaking Buttonizer.

    thevisas

    (@thevisas)

    Hi,

    Thank you for your reply.
    The plugin has been working and the current call can be closed.

    However, regarding FA4.3 could you please clarify the following.
    In the FAQ section of your website https://buttonizer.pro/faq/ one of the questions (My icons are not showing in my floating buttons?) refers to FA4.7.

    As I mentioned before FA4.7 is already part of the theme used on the website.

    So the question is whether Buttonizer can use FA4.7 that is already part of the theme and not download FA4.3 from maxcdn.bootstrapcdn.com .

    Regards, Vitali.

    Plugin Author Buttonizer

    (@buttonizer)

    Hi Thevisas,

    Thank you for asking, I wasn’t aware of that FAQ Question and for now we do not have the option to disable the FontAwesome 4.3 loading by the plugin.

    We will support that in the Buttonizer 2.0 version with even the possibility to use FontAwesome 5 (instead of FA4.7).

    However, you may be able to change some code.

    When you go to the file ‘[ButtonizerPluginDir]/classes/Button.php’ on line 113 you will see the following:

    wp_enqueue_style('font-awesome', '//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css');

    You can remove this line, then it won’t appear anymore in your webpage. However, when we update Buttonizer this line will be overwritten. So this is an temporarily fix.

    We hope to bring out Buttonizer 2.0 soon!

    thevisas

    (@thevisas)

    Hi,

    Thank you for your reply.

    I was in fact just testing this. It seems that FA4.3 is still required in admin part, so I left it as is in admin.php.

    But it can be safely commented out in button.php for the front-end, provided that FA4.7 is already installed.

    I understand that plugin update will overwrite any modifications.

    Thanks again for your support.

    Regards, Vitali.

    Plugin Author Buttonizer

    (@buttonizer)

    Hey! Yes that code can be safely commented! Should not be a problem 🙂

    Let us know if you have any further questions!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Buttons do not show up’ is closed to new replies.