Support » Plugin: WordPress Button Plugin MaxButtons » Buttons Disappeared after updating

  • Resolved yato1234

    (@yato1234)


    Updated the plugin and now none of the buttons in the database are loading.
    When I go to the manage page for buttons it looks like this https://i.imgur.com/ivFptyZ.png
    So it knows there are 81 buttons but it refusing to load them.
    Found php 7.3 was breaking the plugin so rolled back to V7 but then the buttons were gone.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Bas Schuiling

    (@basszje)

    Is the WordPress you are using also the latest version?

    What errors do you get?

    Also plugin is fully compatible with PHP 7.3 .

    Thread Starter yato1234

    (@yato1234)

    Ok did more debugging, what looks to have happened was that our pro version which was something like 1.4 somehow was able to auto update to 5.09 and in doing that partially imported the buttons into the v3 table (81 of 309) and then everything went to hell as v5 isn’t php 7.3 compatible

    Plugin Author Bas Schuiling

    (@basszje)

    1) I don’t think you should try to mix the PRO and free versions as you might lose out on data. This is the support channel for the free version.

    2) Version 5 is almost 4 years old and not supported, but updating from 1.x to v5 technically should work, but no guarantuees on that. You can try with an older PHP version to do the whole update. It should be cross-compatible.

    3) The current version is 7.13.3 . Older versions might not be compatible with the latest WordPress versions either.

    I am having a similar issue as this. I was on a very early version of the max plugin and upgraded to the newest version, and now all of my buttons aren’t showing. On the dashboard it says that there are 422 buttons, but I can’t actually view or edit them (see link below). Is there a simple way to fix this?

    https://imgur.com/ZwZC2EE

    Thanks

    Plugin Author Bas Schuiling

    (@basszje)

    How old was your version? If it’s something much lower than 5, see above comments and see if that works.

    In the plugin settings under advanced there is a ‘remigrate’ button. You could try and see if that works, if the migration didn’t work before.

    Before doing anything **make backups**. Moving so many versions might cause any kind of issues.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Buttons Disappeared after updating’ is closed to new replies.