Support » Fixing WordPress » buttons: change text-transform to “non”, no uppercase

  • that does not work, I inserted it into custom css (plugin):

    .wp-block-buttons {
    text-transform: none!important;
    }

    What is the correct syntax?

    tia
    Eckard

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi,

    Please add the following CSS in custom CSS section,

    .wp-block-buttons {
    text-transform: lowercase !important;
    }

    Thanks,

    Thread Starter egerlach

    (@egerlach)

    thx.
    I tested that already. Does not work.
    BTW: background-color: red;
    works. Just as test if that css is reached. YES, it is reached.

    Another idea?

    tia

    where you wan to add this style. can you please share URL of the page?

    Hi,

    If you have a cache plugin or server cache. You need to purge it’s cache contents and then test the CSS result. Hope this helps!

    Thanks

    Thread Starter egerlach

    (@egerlach)

    I cleared cache every time ith ctrl-F5 before.

    Here is an example with a button:
    https://webarchiv.zeitprax.com/testpage/

    BTW:
    h5 {
    text-transform:lowercase !important;
    }
    works, all h5 headlines are lowercase now. But does not worl with buttons.

    Who knows why?

    tia

    muktadhawan

    (@muktadhawan)

    TRy This:-

    .wp-block-button__link strong em {
    text-transform: lowercase !important;
    }

    Thread Starter egerlach

    (@egerlach)

    Thank you! works!
    I changed “lowercase” to “none”, now I have what I want:

    .wp-block-button__link strong em {
    text-transform:none !important;
    }

    same I did with h5: “none” instead of “lowercase” !

    For other readers: WP editor and preview doesn’t show lowercase letters, but final website shows intended letters in lowercase.

    • This reply was modified 8 months ago by egerlach.
    muktadhawan

    (@muktadhawan)

    great. Please marked it resolved

    Thread Starter egerlach

    (@egerlach)

    The hack works only for special buttons, why not for all?

    .wp-block-button__link strong em {
    text-transform:none !important;
    }

    look here: https://webarchiv.zeitprax.com/testpage/ Why second button not affected? What can I do, that all buttons are affected by the css hack?
    I configured second button as yellow button with black font. Why is second button white?
    I can only reproduce second button, not the first. Whats the magic with first button???

    perhaps a new WP-version disabled that hack.

    Somebody here has a idea?

    BTW: prevent uppercase for h5 still works:
    h5 {
       text-transform:none !important;
    }

    • This reply was modified 5 months ago by egerlach.
    • This reply was modified 5 months ago by egerlach.
    • This reply was modified 5 months ago by egerlach.
Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.