Support » Plugin: Post Snippets » Buttons aren’t working anymore

  • Hi,

    I have this plugin on several sites and it works well. But on one of them, it stopped working. I mean the shortcodes are still displayed correctly on the front-end. But I can’t edit or add any snippet.

    When I click on “Update Snippets” or “Add New Snippet” I’m redirected to a 404 page. I don’t understand why. I have deactivated and deleted the plugin, then installed it again but it’s not fixing anything.

    I’d appreciate some help.

    Thank you.

    Best,

    Midas

    • This topic was modified 4 months, 1 week ago by  midasking777.

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • I have the same issue.

    Have you found a solution for this ?

    Unfortunately, I haven’t. I tried to update the snippets directly in the database. But the result was that I lost them all…

    After that, I could create and edit the new snippets. But I have an error or 404 each time. Despite the errors, I can create and edit snippets.

    Plugin Author GreenTreeLabs

    (@greentreelabs)

    Hi, what is the role of your user? For editors post snippets settings must be enabled through adding:

    define('POST_SNIPPETS_ALLOW_EDIT_POSTS', true);

    in your wp-config.php

    is that case?

    Cheers,
    Diego

    • This reply was modified 2 months, 3 weeks ago by  GreenTreeLabs.

    Hi Diego,

    I’m an administrator.

    There’s only on one of my sites that I have had this error. And I’ve been working on about 30 sites where this plugin is installed.

    This is the message I get: http://prnt.sc/n5077n

    The URL is fine /wp-admin/options-general.php?page=post-snippets and if I use the same URL I go to the correct page. But when I click create or update, I get this message. Fortunately, the snippets get created and updated. But it would be nice to work smoothly.

    Best,
    Midas

    Plugin Author GreenTreeLabs

    (@greentreelabs)

    Oh that’s interesting so my guess is Chrome is detecting some PHP o HTML code “thinking” it’s evil code. Would it be possible to get the snippets you’re using on the site with the issue? If you prefer you can send them to diego@greentreelabs.net

    I’ve just sent you an email.

    Thank you.

    Plugin Author GreenTreeLabs

    (@greentreelabs)

    I imported your snippets, I was able to save without errors. Maybe you have some security addons for Chrome?

    Hi Diego,

    Sorry for the late reply.

    I was working on another site today and I managed to recreate the bug! Accidentally.

    I’ve added a snippet with the MailChimp signup code to this other site. And boom! Same problem. I have deleted the snippet and it’s working again…

    Regarding security add-ons, I have an adblocker and a VPN extension. Maybe one of these 2 flags the code as a threat.

    Plugin Author GreenTreeLabs

    (@greentreelabs)

    I’ll refactor the whole snippets saving flow, should be able to do it this week, Finger crossed (worst thing for a developer is not being able to replicate the issue).

    Plugin Author GreenTreeLabs

    (@greentreelabs)

    I had interesting feedbacks, it seems the 403 error is fired if you also have installed plugins for JavaScript optimization, I don’t know which plugin unfortunately, I hope to get an answer about that soon.

    Do you have any plugin with such functionality?

    I’m using W3 Total Cache for optimization.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.