Support » Fixing WordPress » Button will not center on live page.

  • Hi all. I’m trying to center a button. I went to Customize -> Additional CSS and entered this class:
    .aligncenter {text-align:center;}
    Then I went to a buttons block and entered the .aligncenter class for it.
    It shows the button centered in the editor. But not when I view the page.
    I hit F12, right clicked the refresh button in the tool bar and clicked Empty Cache and hard reload. But no luck.
    Anyone know why this would be happening?

    • This topic was modified 1 year, 3 months ago by Jan Dembowski. Reason: Moved to Fixing WordPress, this is not an Everything else WordPress topic
    • This topic was modified 1 year, 3 months ago by Steven Stern (sterndata).

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hello @smiller781,

    This button is already in the center https://ibb.co/hFjwKqx

    kindly clear cache & Browser cookies or check-in incognito

    @smiller781: Your site has your host’s default “Coming Soon” page on, so we can’t see the page with the button in question and help you out.

    Thread Starter smiller781

    (@smiller781)

    @ethicalimran not in the center. I stated in my thread I did a hard reload and cleared cache.

    Thread Starter smiller781

    (@smiller781)

    @gappiah I took the coming soon page off. You can see it now.

    Below is a full-page screenshot of what I see when I view your homepage. I don’t see any “button” anywhere. I even checked all the inner pages as well.

    Can you please direct me to where this “button” is located?

    Thread Starter smiller781

    (@smiller781)

    @gappiah – Sorry I was editing last night. I got it to work somewhat. I had to put .aligncenter class on both the ButtonsGroup element and the Button element for it to work. Now I need to put some space on the bottom of the button. I am also having problems with a hover affect. When I put the hover class from Hover Effects plugin on the image in the black background column, the hover class works but the image loses it’s center alignment and becomes left aligned. It then doesn’t look good on hover because it is expanding outside of the black background column.

    I’m not sure how to upload screen shot for what I did.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Button will not center on live page.’ is closed to new replies.