Support » Plugin: Style Kits - Advanced Theme Styles for Elementor » Button style conflicts with Elementor Pro and looks broken

  • programmin

    (@programmin)


    The Elementor Pro feature clobbers the styling of of this – if there were just one more bit of specificity, say “body.elementor-kit-25 .elementor-button” in every place you have “.elementor-kit-25 .elementor-button”, it would be working and overruling that transparent in the /elementor-pro/assets/css/frontend.min.css in their plugin.

    You can see it in inspector here:
    https://imgur.com/a/z7K1156

Viewing 6 replies - 1 through 6 (of 6 total)
  • gvgvgvijayan

    (@gvgvgvijayan)

    Hey @programmin,

    Could you please reach us to throw our direct support by sharing the temporary admin credentials to logged in and the page where the issue is happening? This will be helpful for us to get more information about this issue.

    Thanks,
    Vijayan G

    Thread Starter programmin

    (@programmin)

    No, that should not be necessary You can see exactly where the button background is overruling it in the screenshot linked.

    gvgvgvijayan

    (@gvgvgvijayan)

    Hi @programmin,

    Thanks for your response, we will check and fix that.

    gvgvgvijayan

    (@gvgvgvijayan)

    Hi @programmin,

    We tried to replicate in our development environment by adding new Elementor PRO CTA widget and everything work fine from both editor screen and view page (please check the screenshot where button BG color was applied from SK CSS). Could you please share the steps to reproduce?

    Screenshot: https://imgur.com/a/EG0lEh6

    Thread Starter programmin

    (@programmin)

    After updating the plugin that background issue does seem fixed, thank you.

    It still does not show the hover background color, just transparent from the pro-plugin css.. unless the style kit > button small settings > hover color is chosen.

    Thread Starter programmin

    (@programmin)

    One other strange thing with the CTA button, is that border the Elementor-pro puts on in css, “None” in settings of style kit doesn’t get rid of it but 0px standard border does work.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Button style conflicts with Elementor Pro and looks broken’ is closed to new replies.