Support » Plugin: Sticky Side Buttons » Button doesn’t showing

  • Resolved Neeraj Kumar

    (@neeraj-jangir)


    Actually button div and css is appear when you inspect but i tried all things button isnt show on my website.
    May is it will be showing after some css code, but i dont know what code need to use.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • wuex

    (@wuex)

    I could not identify any reason other then some theme interference with sticky Side or WP itself. In my case, all action buttons from the theme (Menu open) and that from sticky side first appear in construction but without rendering completely (is that the right word?). One can see that something is formed in the screen but is not complete and one cannot say what for, until the time when any other button is acted, for instance another menu option. Then everything appears bright and shine. Or WP is reading some code only after the first charge, upon anything more is acted. That is why I feel that maybe something is out of order inside the coded lines perhaps related to WP itself. Therefore I dunno if it is from WP or from the way the theme was built.
    But considering that also the theme buttons suffer the same effect, for now I am pretty sure sticky side buttons has nothing to do with that.

    Neeraj Kumar

    (@neeraj-jangir)

    No worry, issue is solved. I wasnt delete this question because here is no button to delete a query on wp site.

    wuex

    (@wuex)

    So How was it solved?

    Plugin Author Maeve Lander

    (@enigmaweb)

    In most cases when the button isn’t showing it’s because something is layered over the top of it with a higher z-index.

    In the plugin settings there is a field where you can define z-index for the buttons. An element with a higher z-index is always in front of an element with a lower z-index. If you have tried a high z-index in that setting but your buttons still aren’t showing, it is likely that your theme has a very high z-index specified somewhere. This is not great practise, but is sometimes done in complex themes with lots of layered design elements, and also with page builders. As a last resort you can use CSS to force override the z-index for your buttons: #ssb-container { z-index: 9999 !important; }

    If you share a specific example I can use the element inspector to try to work out the culprit on any given site. But without a link to the affected site, it’s impossible to give more help than the general pointer above per the FAQs.

    wuex

    (@wuex)

    The affected site is yidishmusic.com.br
    If you drop by let me know.

    wuex

    (@wuex)

    NO, Z-index is not the point. I tested it. The menu button of the theme has also same effect. I guess is something with WP directly and nothing to do with the sticky app.
    When the theme presents same effect, it is time to get back to the main code.
    Thanks anyway. If something more passes your mind about it, tell me.

    Plugin Author Maeve Lander

    (@enigmaweb)

    Sorry Wuex – I visited your URl but site looked completely broken to me. Screenshot: https://cld.wthms.co/UdzBV4

    WOW! Thats awkward! All the tests I made around the planet did not show that….
    That is realy odd. How do I place a picture here in a way you can see it?
    SO I can show you the effect I am talking about.
    I am a beginner anyway…

    Actually site background was white and button background too, thats why i was’t understand the issue but it is solved myself after sometime.

    Problem solved. Site is building ok and Sticky Buttons are showing and working with no problem. My recipe this time: Changed webhost. I guess that was a processor/memory speed issue from the older webhosting company.
    OK, it was a free one, cannot complain. Now it is a payed one. I decided to do things the right way.
    Thank you for showing me how the site was looking like from your side.
    Congrats on the Sticky Buttons plugin. Have already provided 5 stars!

    • This reply was modified 4 months, 3 weeks ago by  wuex.
    • This reply was modified 4 months, 3 weeks ago by  wuex.
Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.