Support » Plugin: Protected Posts Logout Button » Button Doesn´t logout til´refresh

  • Resolved robertofvg18

    (@robertofvg18)


    Hi, the button doesn´t work properly. I can login with the password “123456” without problem, but when i press logout button i read the message “logged out” but is still in the same page, this until i press f5 to refresh page and now is logged out correctly. How can I fix this?. My theme is “Hestia”

    Thanks,

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Nate Reist

    (@natereist)

    hi @robertofvg18 it appears your server is showing a cached HTML file likely because of a caching plugin. It appears the expires header for the page HTML is 7 days, so you either need to clear your cache or use a browser tool to disable caching to see the logout screen again.

    I think you would fix this by excluding the password protected page from your caching plugin ( LiteSpeed Cache ) on the setting page pictured here: https://ps.w.org/litespeed-cache/assets/screenshot-4.png?rev=1851289.

    So is a configuration on my browser?

    Because I just disabled LiteSpeed Cache, and the issue is the same.

    Plugin Author Nate Reist

    (@natereist)

    @robertofvg18 it could also be the settings on your server for HTML page caching. The expires for the page when I load it is 7 days from now, so your browser wants to keep a local copy of the page for 7 days before loading it again. Your server could have expires headers set like this in an .htaccess or configuration file:

    <IfModule mod_expires.c>
    ExpiresActive on
    ExpiresDefault "access plus 1 month"
    <strong>ExpiresByType text/html "access plus 7 day"</strong>
    </IfModule>

    It is also possible that your browser is caching the page even though you’ve disabled ( since thee browser already cached the header ).

    I would recommend making sure your server does not set expires headers to cache text/html.

    Plugin Author Nate Reist

    (@natereist)

    @robertofvg18 I’m going to close this topic.

    Feel free to open another one if you experience more issues.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.