• Resolved fiberlyone

    (@fiberlyone)


    Your plugin works brilliantly, but I’m having an issue with the button color. I found the post from over a year ago that said the button color is generated by the theme I am using – Hueman.

    I activated the plugin on a test site. I couldn’t find an option to change the button background color in Appearance – Customize, so I changed the color in the style.css in my child theme.

    .widget a {
    color: #ffffff;
    }

    a:link {
    color: #bc4242;
    }

    /* visited link */
    a:visited {
    color: #bc4242;
    }

    .button {background-color: #ffffff;padding: 8px 14px;margin-left:30px;margin-bottom:50px;font-size: 18px;color:#ffffff;border:none;border-radius: 3px;}

    And it worked – viewed on a Mac in Safari and Firefox (but not in Chrome) and on an iPad.
    Testing Site

    I made the same changes on my working site child theme style.css. I compared the two css pages to be sure. But on the working site, it still has the colored buttons.
    Working site

    By all accounts everything is the same, except for the button background.

Viewing 4 replies - 1 through 4 (of 4 total)
  • fiberlyone

    (@fiberlyone)

    And suddenly it’s working. Five minutes ago, the button background on the working site was red, now button background on the working site is now white.

    Plugin Author Michael Nelson

    (@mnelson4)

    Oh that’ll drive you crazy! I bet your browser or server was caching the CSS file on the live site.
    Anyways- looks pretty slick!

    … Although as an unauthenticated user, the print page isn’t working for me. That’s because the behind-the-scenes AJAX request to https://www.columbiariversewing.org/wp-json/wp/v2/ is being denied by some security software (either a plugin, or server-level security, I’m not sure.) I’m getting that problem on both sites.

    fiberlyone

    (@fiberlyone)

    I have Cerber installed. Based on a cursory test, it appears that the latest update is the cause.

    Another plug-in stopped working, citing REST API. Additionally, when I first installed Print My Blog, I recall a similar issue. I added print-my-blog and the other plug-in to the namespace, along with my role. I could print when logged in, but the other plug-in did not work.

    I deactivated the latest version of Cerber, moved it out of my plugins folder, then installed an older version. Now both plug-ins seem to be working.

    BTW, Google Chrome took 24 hours to uncache the button color. All is well. For now.

    Thanks.

    Plugin Author Michael Nelson

    (@mnelson4)

    I haven’t tested it before with Cerber, but I just poked around and saw they have quite a few settings for disabling the REST API. I think you either way to enable the REST API (eg by leaving this setting disabled), or enable the routes used by Print My Blog (I believe they’re wp/v2/taxonomies, wp/v2/posts, and wp/v2/pages). I’m not 100% sure because I actually haven’t quite managed to get Cerber to work locally.

    Anyways, if your issue is solved satisfactorily I’ll close this issue for now. Thanks for reaching out.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.