Support » Plugin: reSmush.it Image Optimizer » Bunch of problems with reSmush.it

  • Hello there,

    I used WP Smush once. I recently discovered reSmush.it. I liked the compression performance and used it on several sites and recommended it to my friends. I didn’t notice it at first, but when I investigated it deeply, I detected a few problems.

    1. All pictures before the first time I installed the plugin were corrupted. I can see them, I can use them, their files on the server, but I can not do any action in the WordPress media library. I have experienced this problem on two different sites, but I did not face on other two sites. Now I’m trying to erase the images one by one and upload them one by one again.

    2. I’ve encountered a second error while performing the renewal process. When loading the image, WordPress media library started to issue “HTTP Error” message. I didn’t understand what happened at first. I tried again and again, but the result was always the same. Disabling the reSmush.it plugin’s “auto optimize on upload feature” has solved the problem.

    3. But this was the beginning of a new problem. I can’t optimize the images I uploaded to the site right now. I don’t know why, but I can’t compress uploaded images after disabling auto optimize feature. reSmush.it status always appears as “Reduced by 0 (0 saved)”.

    I am not in favor of using other plugins. Because the performance of the plugin makes me happy. I need a solution, but I can’t find out what it is. I thought it would be right to write here. Please fix these errors. It’s really exhausting to have to deal with the same things over and over again.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author reSmush.it

    (@resmushit)

    Hi Kaan,

    Not sure in understood everything, but :
    – how do you know that pictures are corrupted, and you think this is linked to reSmush.it ?
    – We’ve had in yesterday and today an issue with one of our server which wasn’t responsing correctly, which may be the root cause of your points 2 & 3. It has been solved 2 hours ago, so the service is running normally right now.

    Do not hesitate to send us more details using screen captures and/or log details, we’ll try to help.

    Cheers,
    Charles

    Hello,

    First of all thanks for the answer. I noticed the pictures were broken when I try to edit them. Some of the pictures are still broken. Because the renewal process is time consuming. As an example, you can check this link and see my article.

    This is one of my most important articles. You can easily see the featured image. You can access it when you copy the image address of the image. Just like this and you can see it.

    However, I cannot see the thumbnail of this picture in the media library. Instead of thumbnail there is just a simple point or dot below the file section (when you search it in media library.) When I clicked on the image and then “edit image button”, the message like this: “Image data does not exist. please re-upload the image.” There are currently about 500-600 photos in this manner in my site.

    To sum up here,

    1. The file is on the server.
    2. It is possible to reach it with link.
    3. However, it is not possible to make any adjustments on it in media library or in posts.

    This problem occurred after switching from WP Smush plugin to reSmush.it plugin. At first I thought the old plugin was a nuisance. However, after installing several images everything was perfect. The same thing happened after a reSmush.it update. So I started to think that the problem was caused by reSmush.it.

    It would not be quite right to say anything definite about it. Maybe something else could have caused the problem. Because I changed the theme and started to use Regenerate Thumbnails plugin. Maybe there might be a conflict here. I will give feedback if I encounter a similar situation. However, I believe it would be useful to check.

    Plugin Author reSmush.it

    (@resmushit)

    Hi Kaan,

    Thanks for this feedback, I think you should have a look at your PHP error log, as you’ve performed different changes on your website, there should be something with one of them.
    A tip should be to look at your files permissions to check if everything run well.

    Keep us posted,
    Charles

    marijsvrancken

    (@marijsvrancken)

    Hi,

    Did you end up solving this problem? I’m experiencing the same problem, it’s very frustrating.

    Thanks!

    Hi @marijsvrancken,

    I can’t solve my problem. I re-uploaded all of my images from scratch. But I don’t think the problem is ONLY related to this plugin. The problem was a one-time problem, but I have various doubts.

    1. I was using the Regenerate Thumbnails plugin. What happened to me already came after running this plug-in. Because I used reSmush.it three different sites but there were problems on two sites. There was no problem in one. I don’t remember running Regenerate Thumbnails there.

    2. I went to theme change on both sites where I had problems. Maybe the problem is related to this. At least a possibility.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Bunch of problems with reSmush.it’ is closed to new replies.