WordPress.org

Forums

BulletProof Security bug (15 posts)

  1. yos.c.bd
    Member
    Posted 3 years ago #

    hi everybody,
    i have installed a new Hebrew 3.3.1 WordPress site on my server,
    i also installed the BulletProof Security plugin and consider to buy the PRO version.

    for some reason after installation of the BulletProof Security it doesn't work.
    i go to the BulletProof Security settings and all i see is the plugin title and the "why upgrade to BulletProof Security pro" title.

    i don't see the BulletProof Security admin panel.

    i do have an older version of BulletProof Security - 46.6 that is working just fine but i want it to be updated and as for now i can only work with the old version as the 4.6.9 doesn't work...

    anybody can help?

  2. AITpro
    Member
    Posted 3 years ago #

    You are the only person that has reported this problem so the problem is specific to your website / website config and is not a bug in BPS. have you tried completely uninstalling BPS and then reinstalling? Do you have any other plugins that would interfere with installing BPS? No one has every reported this problem so i am not really sure what to tell you here. Thanks.

  3. AITpro
    Member
    Posted 3 years ago #

    The cause for this problem is you are using PHP4 and not PHP5 on your website. You can change which version of PHP that your website uses in your Web Host Control Panel or cPanel, whichever you have. BPS requires PHP5 in order to work. PHP4 has been deprecated and should no longer be used.

  4. AITpro
    Member
    Posted 3 years ago #

    The new coding that requires PHP5 or BPS will not display correctly is the new Download / Ratings code added in .46.8 and .46.9. I will be correcting that code in the upcoming BPS .47 release so that the BPS PHP4 version error message is displayed correctly.

    Language Translation i18n coding has been added to BPS .47 and language translations will be the focus of the next few BPS version releases. Anyone interested in providing translations to their preferred language are more than welcome to contribute a translation. A Translation section with links to Translators websites will be added to the main BPS Description page.

  5. yos.c.bd
    Member
    Posted 3 years ago #

    thank for the quick reply :)
    I do have PHP 5...
    i upgraded to PHP5 long before i installed BPS...

    right now 4.46 works just fine on my site, problem started with later upgrades 4.48, 4.49....

    not only i don't see error message, i dont see the admin panel at all...
    i try to install the BPS on 2-3 wordpress sites all of them are with PHP5.
    also all of them are in hebrew

  6. yos.c.bd
    Member
    Posted 3 years ago #

    just installed an English version of wordpress and the BPS,
    i'm having the smae problem so it is not a language issue - the problem is with me :)

    i do have PHP 5, can you think about any other reason for the BPS not desplaying the admin panel?,

    if you give me an email address i can attach a prints screen....

  7. AITpro
    Member
    Posted 3 years ago #

    No need for screenshots. If something is not displaying then that means your Server / website is not processing some BPS code correctly and is exiting the script because it is failing. Do you see the Star Rating at the top of BPS? You should see 5 gold stars. What changed starting with .46.8 was the WP Star Rating coding was added. So something on your Server / website cannot process the Star Rating coding.

    I suspect that it has to do with this WP function: number_format_i18n. I will be releasing BPS .47 very soon so maybe this will work on your Hebrew site because the issue appears to be a i18n language translation issue that is not be working correctly for whatever reason.

  8. yos.c.bd
    Member
    Posted 3 years ago #

    i do see the stars, rating and the recommendation upgrade to BPS pro but other then that i don't see anything, after the stars and the "upgrade" title the page is blank...

  9. AITpro
    Member
    Posted 3 years ago #

    Ok here are some troubleshooting steps you should try.

    1. As of BPS .46.7 the new jQuery Read Me buttons were added to replace the old Hover Tooltips. If you have javascript disabled in your Browser then you would still see the BPS pages, but everything would be display broken. Since BPS .46.6 is working then it could have something to do with jQuery not working correctly on your website.
    2. Deactivate all your plugins except BPS and see if BPS pages display correctly.
    3. Are you using php.ini handler code? If so, double check that it is the correct php.ini handler code for your Server / web host.
    4. Do you have a php error log set up? If so, check your php error log for errors that could give away the reason BPS is not working on your Server / website.
    5. If you are using a custom php.ini file then temporarily rename it to _php.ini to test if this is the problem.
    6. You can try adding the WP_DEBUG code to your wp-config.php file and see if it tells you anything about what might be wrong on your website.

    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', true);

    7. Try switching to the WP 2012 Theme temporarily if you are not already using it.

  10. yos.c.bd
    Member
    Posted 3 years ago #

    first of all - thank you very much for your help - i appreciate it! :)

    1 - java script is OK
    2 - i installed "new" wordpress, onely plugin i have is BPS
    3 - no
    4 - no
    5 - i'm not
    6 - i did and now i see this:

    Notice: Undefined variable: bpsCCTop in C:\HostingSpaces\my domain \wwwroot\wp-content\plugins\bulletproof-security\admin\options.php on line 518

  11. AITpro
    Member
    Posted 3 years ago #

    The undefined bpsCCTOP variable is an insignificant PHP Notice that was missed in the debug check in .46.9. This is has been corrected in .47.

    And i am out of ideas for things you can check. I am not sure what is wrong with your website or wrong on your Host Server. Maybe your web host support folks can help you figure this out. Thanks.

  12. AITpro
    Member
    Posted 3 years ago #

    Oh wait a minute - Is this Windows Hosting? The path you posted above is C:\HostingSpaces\my domain \wwwroot\wp-content\plugins\bulletproof-security\admin\options.php on line 518

    You CANNOT use .htaccess files on Windows Hosting. .htaccess files will ONLY work on Apache Linux Hosting. You cannot activate BulletProof Modes on Windows Hosting. See this WordPress Codex page for more info >>> http://codex.wordpress.org/Using_Permalinks#Permalinks_without_mod_rewrite

  13. yos.c.bd
    Member
    Posted 3 years ago #

    yes it is, sorry i haven't mentioned it before :(

    if i follow the instructions and add the rewrite code will the BPS work?
    or there is no way to make it work with windows server?

    <rewrite>
    <rules>
    <rule name="Main Rule" stopProcessing="true">
    <match url=".*" />
    <conditions logicalGrouping="MatchAll">
    <add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
    <add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" />
    </conditions>
    <action type="Rewrite" url="index.php/{R:0}" />
    </rule>
    </rules>
    </rewrite>

  14. AITpro
    Member
    Posted 3 years ago #

    You would have to meet all the necessary conditions to make this work on Windows IIS hosting and then you would have to recode BPS to use a web.config file instead of .htaccess files.

    I think it would simpler just to create the custom web.config file manually based on the BPS security filters (basically translate them). Translating the BPS .htaccess files to web.config would not be a difficult thing to do. The big deal is all the other prerequisites and factors involved with Windows IIS hosting.

    Someday I may try and tackle this, but because of all the prerequisites and special conditions with Windows IIS hosting i think this would be a nightmare to try and support. So if i do try to take this on it would not be for several months. nginx is actually next on my list to tackle. Thanks.

    "Pretty" permalinks usually require mod_rewrite, and IIS (common on Windows servers) does not support mod_rewrite. (If you are using Apache 2.0.54, on Windows, mod_rewrite may work, provided it is enabled in apache\conf\httpd.conf.)

    If you are using IIS 7 and have admin rights on your server, you can use Microsoft's URL Rewrite Module instead. Though not completely compatible with mod_rewrite, it does support WordPress's pretty permalinks. Once installed, open the web.config file in the WordPress folder and add the following rule to the system.webServer element

  15. AITpro
    Member
    Posted 3 years ago #

    Please resolve or close this thread. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic